Picsender does not recognise COM port


So I decided to give PicSender a try - downloaded the latest version, but it refuses to recognize the COM port.

I double checked with Easel and Chilipeppr and they see COM5 115200 fine. I made sure to shut them both down so there is no resource being held up by them before trying PicSender again.

Still no joy. Anyone else experience this?


I just downloaded 2.5.9 and it works fine here.

What happens when you try to open the COM port? Do you get any messages? Post them here.

1 Like

I get the error stating that the USB port cannot be found.

Windows? Check device manager and see if the port is there

1 Like

Yes it is as it works for Easel fine. I tried changing it fro COM5 to COM1 and from 115200 to 9600 - no joy.

Try rebooting the computer and don’t run any program before you try PicSender and see if that makes a difference.

1 Like

Ok, will try that. Thanks

Thanks Robert…tried that. Didn’t work.

Do you use a powered usb hub?

1 Like

Thanks @LarryM @RobertCanning & @MarcCohen for trying to help Steve with PicSender. I had to get away from this PC for awhile. :slight_smile:

The only thing I can think of other than what has already been suggested, we found one version of grbl 9j that PicSender will not connect to and it’s the hex download on this inventables support page.

i just tested it here again and PicSender comes up with this message.

@SteveCarter is that the version of grbl 9j firmware your using?

If you follow the Link on that support page to the inventables Fork on Github, the 1.0c grbl hex download will connect with PicSender without any issues.


Just a point of reference. I have tried several times to use that .hex file and it will not work in any Arduino I have (8 of them).

I have compiled from source for that version with success.