Port Problems!

So up till today, the X CARVE had been running fine and I have been running the machine now for about 3 weeks!! Today in the middle of my project the machine just stops running. I look at the console and it says error can not connect to port. Input output error, and I don’t have any control to UGS! If I close UGS and reopen it I still can’t connect to my port. But if I restart my computer I can connect and restart the project but half way through does the same thing again!! I have no idea what to do!

I tried to connect port with Easel and numbers aren’t coming up for a port option! The only option its giving me is ( : )

The Json driver is using tricks to make your PC’s USB port look like a COM port. The port is still a USB port as far as the PC is concerned though, and your PC may be timing out the USB ports to save energy. Look into your PCs power saving settings, and disable them all. 4D

Ok so I went into my control panel> system> power options> advance settings and disabled sleep. But I also see something here that says “USB selective suspend setting” and that is enabled! Do I need to disable it?

And here is the error Im getting in UGS

My problem solving strategy usually includes try every option until I stumble across one combination that works. I don’t have the setting you mention on my laptop, but if I did I would enable it then see what further control I had access to. You are looking to turn off anything that messes with your USB ports. 4D

@ThomasGonzales did that fix this problem?

no

@ThomasGonzales
In instances like this I always remember that Google is my friend, I did a search on the error and it appears in quite a few threads with some possible fixes, https://www.google.com/webhp?sourceid=chrome-instant&rlz=1C1CHLB_enUS493US493&ion=1&espv=2&ie=UTF-8#q=ioexception%20while%20sending%20status%20command%20input%2Foutput%20error%20in%20writebyte

Give it a try, it can’t hurt

So I read that it could be the USB that its plugged into, so I have now tried all of my USB ports that are on this laptop and checked the connection going into the arduino and I am still getting the same thing.Im also reading that this could be a result of the spindle going out or being bad! Could this be a possibility?? While running a job the spindle and mount are getting pretty hot, I dont know if that has anything to do with it!! here are a couple of links that it was mentioned about the spindle and USB port:

one was on GitHub: https://github.com/winder/Universal-G-Code-Sender/issues/122

The other was on shapeoko forums: http://www.shapeoko.com/forum/viewtopic.php?t=3575&p=26880

But so far not fixed yet!!

I don’t understand how the spindle could be involved.

To rule that out unplug the spindle and try to connect the USB.

Does the Arduino connect then?

Correction, while we’re working on Bad Spindle troubleshooting, Arduino shut off, no port assigned in device manager. I pulled GShield. pressed reset button on Arduino, then I’ve heard my computer dinged, put shield back, power on, com port came back. If it make sense.

So if I understand correct, you had a bad spindle and it shut down your arduino and you lost connection to your port. you reset your arduino with the reset button and you were able to connect to the arduino port, correct?

Also If I shut down everything (my computer and arduino) and restart everything I can get connection back but then it does the samething a little ways into the project but I have not tried the reset button.

So I disconnected the spindle and the switch to the off position, I reset my computer and arduino and Im running the same G code right now.

It has already gone way farther than I could have earlier as you can tell in the pic! the carving starts at the S and works backwards.

It did finish the whole projects without getting that error! Im guessing something to do with the spindle???

Wait so now it works?

Do you have the spindle set up on “logic” or “on/off”?

The project finishes with the spindle wires detached and the switch is in the off position, meaning I am only simulating the project and not actually running the spindle.

If you plug the spindle in and put the switch to “on” in manual mode does it work?

You can do an air job. No need to carve material to test.

Sure I will go set that up right now!

1 Like

Well that seemed to run just fine as well, so I put the spindle back into logic and running the project without a bit in it.

1 Like

OK so I got the error. I am only getting an error when the spindle is in Logic!

1 Like