Port Problems!

By the way the on position still works fine, it seems like its getting to full rpms. its just the logic that isnt working

Awwwwwww. Im so frustrated!

OK so now I cant even open UGS! I click on the icon, it thinks for a minute and nothing. so mind you all of this stuff has been happening in UGS. Back in Easel I cant even connect to the port. When I go to Machine set up to connect to a port, the only option it gives me is a semicolon ( : ) and thin it just thinks until I exit out. One time I let it sit there and think for 3 1/2 hrs.

Is this in spindle on or logic mode?

Do you have another computer to test to verify its the Arduino and not an issue with USB on the computer?

Hmmm. I have a desktop that I was going to use, but it doesnt have a wireless network card yet so I would be able to connect for easel…Oh wait, I have a couple computers that Im fixing and cleaning up for other people. I might be able to clean one up in a couple hours and try it on one of those!

OK so here is where I stand on the issue: Besides the original laptop I started off with having a problem, I now have tried 2 other laptops.
The first laptop was a computer that I just fixed and removed some viruses. Its running Window 7 ultimate.I downloaded the Arduino environment, plugged in the Arduino and it actually took the driver install sucessfully, which I thought it was suppose to not be successful and then I was suppose to update drivers or something like that? Anyways I tried to update it anyway and it said all drivers were up to date! So I log into Easel and download the Easel Loal and then try to set up machine. It cant find the port the Arduino is on! I close Easel download UGS and Java, open UGS and try to connect the port and it says port not in use. So I go back to device manager and it clearly says the Arduino is on COM4. I tried changing it to COM6 and still wont connect.

The second computer had Windows 7 and did the exact same thing as the first. Then I restored to “out of the box” factory recovery running Vista. Download Arduino environment, plug in Arduino and drivers did not install successfully this time so I go into device manager update the drivers successfully , download Easel Local, machine set up everything works. But now I cant install UGS or Java. Java had an error code 1606, which is a corrupt MSI, so right now I am updating my windows completely and then try again!

In conclusion: its seems like its a computer issue, more specifically a Windows 7 OS issue, but I am not sure if its multiple issues and the computer is one of 2 or more issues. Once I can get UGS up and running and connected, then I can test the spindle in logic again, see if I have spindle rpm control back and go from there.

First question: Is there something in particular about Windows 7 that is causing these problems?? Im sure there are people that are running windows 7 without issues so Im not sure why this Arduino is not connecting to Windows 7.

Second: If I get a brand new computer running Windows 7 or Windows 8 and it comes up with the same problems, is it safe to say that it is an Arduino problem and get it replaced? Its odd that it would work for Vista And not Windows 7.

Thats were I am at right now!!

Reading through this thread, it looks like you had it working, you flipped your fan over, it was still working, and then it stopped. Did anything else change?

It looks like your computer can pick up the Arduino’s com port correctly (I’m using Windows 7 and it’s working fine, btw), but Easel/UGS aren’t detecting it. I wonder if somehow your grbl install got wiped out? At this point it seems like attempting to reinstall the X-Carve grbl version is worth a shot, since the other option is you need to replace your Arduino.

Here’s a link to a thread about re-flashing your Arduino, maybe it will help:

I would say sure but I got easel working now but only on Windows Vista, so that tells me that the Girl program is still in the Arduino, right?? The issue now is I can’t get Java on the computer with Vista on it, I get an Error 1603 did not install completely, or on windows 7 I can’t get the Arduino drivers installed correctly!!

And by the way if I can’t connect to the Arduino port, then I can’t install the Hex file into the Arduino cause the Arduino and computer won’t communicate, right??

1 Like

It seems like your computer sees the Arduino, since it’s getting assigned a com port. If you’ve gotten Easel to run on a Vista machine, then it would seem that grbl is still installed on your Arduino.

Nothing changed in your setup from when it was working to when it stopped? Does Easel on your Vista machine work reliably if you try it several times in a row (my thinking here is that there might be a loose connection between your Arduino and the grbl shield).

Regarding your java install issue in Vista, it looks like you might be able to uninstall a specific Windows update to get it to install: http://www.computing.net/answers/windows-vista/how-to-fix-error-code1603-java-install-windows-vista/13881.html

1 Like

Doing a Windows update should load the newest fixes and security patches needed to install software. This is a known issue when people restore an older system and all security issues have not been updated or automatic update is not enabled.

UGS wont install without Java and Java won’t install because the Win7 security does not recognize the newest version.

Once fully updated Java has an older version removal tool that you can use before trying to load the latest version.

2 Likes

That sounds really frustrating. It’s weird that vista works but Win7 does not. Is it possible there was some windows update that happened between the last time you used the machine and now that messed up the Arduino drivers?

It doesn’t help your situation at this moment but Microsoft has finally acknowledged the Arduino and is working to include the drivers in Windows 10.

Peter, I did research that as well, Java them selves have said that it has caused problems, thing is I didn’t see that update in my windows update history!

As far as widows updates on my original computer, I’m not sure if there were any updates that may have cause a change in my Arduino drivers. I will have to look at the history by date, I’m thinking there shouldn’t be cause I set that computer to not update without notification!

And the windows update didn’t help, still get 1603. But that was only uninstalling through the control panel! Looks like I’m going to have to go through the registry and all my file to try and get all Java files out before trying again!!

So when I try to install Java in Google Crime, I save the file, then when I try to open the file nothing happen, the file will not install! When I try with IE it automatically starts running the installation but then I get Error 1603!! I’ve tried deleting every bit of Java before installing, still same results!!

Hmm I might have found something, when I updated window and it updated 213 items, none of the service packs were included in that, Java requires vista service pack 1 and 2 for vista!! But when I search for windows updates, none of the service packs come up, then I read that if it doesn’t come up its because I need to update other items first, crazy, I have to update in steps till I get service pack 2 I guess!!

Chrome is not supporting Java anymore. Will ignore Java installation commands. IE is sucks as always. But, for the registry access, you may try Firefox for Java installation, then IE picking up correct Java version from registry values.
Another saying, if Java installation says installation succesfull any way, rest of them start using it. When I read this article, I thought I will be stuck with Mozilla (some how I never like it). But know, everything works fine, especially UGS is working great.

That was a little difficult to understand but I think your saying use firefox to install Java cause Chrome doent support the Install and IE sucks for the Install, and once fire fox installs Java then Java works with the rest of the browsers…right?

1 Like

That’s all I did, I have no JAVA problems at least.

Will do! First I have to get these service packs installed. Work on it after work today!!

Make sure you’re not trying online version of Java installation, must be downloaded and start clean.
Also some one in this forum was trying 64 Bit Java installation on 32 Bit PC. I’m sure you are aware of that.
If you want to know more about 1603 error message, you can check this site, might help.

Yea I’ve seen their video, only problem is I have Vista Home Edition! PDQ Deploy doesn’t work with Home Edition, lol. That’s why I researched further and found that Java for vista requires SP2 minimum so I started updating Vista. Hopefully that was the only reason for the 1603.

1 Like