Inventables Community Forum

Power Surge on USB port error while cutting

I have been using my 1000mm ex carve for a few weeks now. Have cut several smaller projects (20min - 1 hr) created and cut using easel. No issues until today. I tried to load g-code from fusion 360. Code uploaded fine I thought and I sent it to carve. Within 10 minutes I had an error come up and the xcarve stopped. The box reads:

Power Surge on USB port
A USB device has malfuntioned and exceeded the power limits of its hub port. You should disconnect the device.

Then it gives me the option to Reset or Close. I have chosen both and they both do the same thing. The box goes away but then just flashes up the error again within a few seconds. I have restarted the computer, disconnected the USB, shut off and turned back on the x-controller but nothing helps. Whether xcontroller is plugged in or not I still keep getting the same error.

Any ideas? I have used the same laptop each time and have tried switching ports but they all do the same thing.

I was able to run a dell support program to try to fix my issue. It detected no problems but restarted my computer again and the error went away. I went back to Easel and set up a prior carve to run for a test. It all worked great until I set home and told it to lift the bit slightly. As soon as it lifted the bit the error came back and it kicked me out of the carve. Right back to where I was before. That error wont go away. Whether I hit reset or close, it pops right back up and easel wont recognize the xcarve…

Static electricity buildup could be the issue. This happens to me on a Shapeoko when I use a dust boot. I get a disconnect on the USB communication from time to time. I’ve taken steps to address this by installing a ground wire from frame to ground source and another grounding wire running along the vacuum tube then connecting this to frame. I will also add another to the controller. The ground has improved things but my shop is very dry in the winter months so I have to be careful.

I will check that. I used the stock ground wire that came with the dust boot and hose assembly but it could possibly not be dissipating what it needs to. Will add in a frame ground also.

1 Like

I know this is an old topic, but I just had this error pop up for me, and I had a different solution. In my case, the USB cable was the cause of the problem. I disconnected the cable from the X-Carve, and it still gave the error when I plugged it into my PC. I tested the cable on another PC, and the same kind of error happened. I had another cable for my printer and tested that with the X-Carve, and had no issues.

Anyway. Adding this here in case as another possible solution.

1 Like