Inventables Community Forum

Probe failure bug

If you guys are having issues, please send an error report with the machine connected (green carve button) with a description of whats happening. Heres how to do it:

2 Likes

Done.

@EricDobroveanu, can you confirm that the X-Controller is still using an ATMega328 CPU and not the ATMega2560?

SAME. Last night contact was not contact and not contact was contact. but a test probe under the advanced menu worked. weird.

1 Like

I will look at the code later and see if I can determine the delta between versions.
Should’t be too hard as I do a lot of this stuff.

1 Like

im using x controller how do i check?

The processor will have a number on it.

If you look at the large chip in the graphic it has 2560 in the number.
Thats how you can tell.

It’s the Atmega328. Schematic doesn’t say 328P, but it still could be the P version.

1 Like

OK, that’s what I thought, but if it had been the other then the probe pin would have been different, so I was just covering the bases.

do i need to check my x controller?
and has ANYONE got a working probe in easel?

I just got my Xcontroller connected, ran through the setup including Z probe, and with the probe connected and am having the reverse behavior in Easel than expected (always shows contact when no contact is physically there, physical contact shows no contact).

I tested the connections with a handheld DMM and it worked as expected (closed circuit when touching, open when not touching). One thing that seemed strange was that, when using the carriage socket, when nothing is connected, the input shows closed as if there was contact. That seems…odd.

I submitted the info inside of Easel.

Same issue.
also says no plug when plugged
and when unplugging from carriage says plugged suddenly

1 Like

Quick note that I’m seeing the reversed behavior described by others tonight as well. However, I am having no trouble with it at all in Chillipeppr, which is what I use 99.9% of the time to run my X-Carve on things I’ve created in Fusion 360. Probes work as they always have with me now using the 14.99mm value rather than the 3mm thick copper PCB I was using previously.

I’ll be curious to see the fix in Easel, but thus far I’d consider it an Easel-specific issue for me and therefore not stopping me from my normal use of the system. I’ll start doing test carves tomorrow.

I just finished doing the full upgrade kit on my X-Carve. In fact, everything seems to be working perfectly normally after the upgrade including the new X-Controller running off the Raspberry Pi I use as my JSON Serial server for Chillipeppr (essentially puts my X-Carve on ethernet rather than USB from one of my laptops to the controller).

If I can offer anything useful in the testing process, don’t hesitate to say the word!

Throwing it out there that UGCS and the 3 axis touch probe worked flawlessly.

1 Like

I agree. With the probe unplugged I measure 0V at the X-Controller, when I plug in the probe I measure 5V at the probe, and can see the voltage change when touching the ground clip. This seems to indicate an Easel problem and not a hardware issue.
Just ran a test carve and everything seems to be good other than the probe.

checking as we speak

1 Like

Nope still same issue

1 Like

Super buggy. dont touch 0.2.8!!!

1 Like

Phil, you can store your grbl settings in a file and then once you have Easel setup you can use UGS to send that file and it will update your grbl settings (may be able to do it with Easel, but I don’t use Easel so I don’t know if it would work there).

I know the engineering team is actively investigating the root cause. I am sorry things aren’t working as expected. I’ll try to give an update later today.

3 Likes