Problem with Arduino Uno Communication

I was in the process of changing my controller to use the PWM output to control spindle speed. I made the necessary changes to the grbl code and uploaded it. As I moved along with the process, I needed to make a couple of other changes, so did additional uploads. Then, I suddenly lost communication with my Arduino Uno board. When I plug it in, it is recognized by my computer. Arduino IDE and UGS also recognize it (when started seperately), but neither can communicate with it. I have tried starting from the beginning and burning the bootloader via IDE, but it says it can’t communicate with the Uno.

Is my Arduino Uno fried or is there a way to wake it up?


Do you have access to another Arduino you can test?

@Zach: No, I don’t but I can pick up one at our Radio Shack.

Sounds like you may need to burn the bootloader. If you look it up on google there are a ton of places for directions. (oops saw you tried it)

@Brian: Yep, I tried burning the bootloader via IDE but it said no communication. There’s another process I was led to that requires using a second Uno to re-program another Uno. After I get my S2 going with one of the new Unos, I’ll see what I can do with my old Uno.

I always had problems bootloading till I got this guy
It’s a cheap easy fix. Hope it helps

@Brian: I’ll bookmark that for future reference. Looks like a good tool!