Inventables Community Forum

Problem with VCarve Pro 10.5 and Easel

I’ve been using VCarve with my XCarve for some time and had no problems importing the g code into Easel. I just upgraded to the latest release of VCarve Pro and am having problems with even very simple tool paths.

Has anyone else had a problem? Here’s the error I’m getting just trying to cut two lines. I’m using the X-Carve (inch) post processor in VCarve.

Thanks to the community!

Test File 2.gcode (213 Bytes) Test File.crv (24.5 KB)

Use the grbl_tc post processor here.

They jacked up the post processors.

1 Like

Thanks for the quick reply. I checked Vcarve Pro 10.5 and it doesn’t list grbl_tc as a post processor. I tried Grbl (inch), but had the same problem. Do you know of another post process in VCarve that would work?

Mark

You can add the ones I linked into your post processor folder.

Hi Neil,

Sorry, I didn’t understand that your reply included a link (I’m a little new at this sort of thing)

I just did a post to another comment on the forum that I talked with Viectric and they think the problem is with arcs. Grbl 1.1 supports them and VCarve Pro 10.5 does as well, but they think Easel doesn’t. They sent me an updated driver, which I’ve attached.

You know what I know. Thanks for your help :slight_smile:

Mark

X-Carve_inch.pp (4.5 KB)

1 Like

Neil,

I just heard back from Inventables. There is a driver on their download page called vectric-easel.pp that solves the problem as well. I copied it to the My_PostP folder and it appears as the only post-processor choice. It is on the download page under the ‘Vectric Aspire’ icon. Inventables says there is only one Vectric driver.

Easel loads the tool path just fine. I’ll need to cut a part this evening when I get home before I can say for sure that it worked.

Mark

P.S. I posted this same message on the other VCarve Pro 10.5 thread

Basically what happened is vectric made changes to their grbl post processors. The changes were untested. The main issue is that they added arc commands (G2 and G3), but the calculations were not precise enough for GRBL’s checks. You’ll see errors more frequently if you use inches for post processing. Your design can be in mm or inches and you can still use either post processor.
The X-carve post processor, while grbl based, never included arc commands because Easel can’t handle them (weird). So, not only did they jack up the grbl arcs, but they passed that on to any grbl based post processor.
A while back, I had a desire to output a single file with multiple tools. I use CNCjs and have toolchange macros, so I am prompted for tool changes and the machine automatically adjusts the zero based on that new tools length. Anyway, when I modified the post processors, I added back arcs. Many others use my modified post processors and vectric was sending them to individuals looking to add tool changes. Soon enough, it was reported to me that some cases were causing arc issues. I fixed the arc precision issues (easy to change), so they don’t happen again.
Looks to me like a vocal grbl user had a specific need for some changes and they just change the posts.
On another forum, where people use my post processor for tool changes, it was reported that they still worked without issue with the new versions of V-carve and aspire.

1 Like