Problem with Z axis after homing machine

When using Easel to control X-Carve, I use the probe to set the Z axis then for the X-Y axis, click the Home button to move to X-Y zero (which also raises the Z axis to the top of the travel) then set X-Y. When I do the carve, it appears to have the Z axis up at the top of the Z axis travel or at least well above the material surface. I stop the carve, redo the Carve process, using the probe again and select Use Last X-Y without Homing the machine, and everything works fine.

One of the other users of the machine said he has had the same problem. He discovered that he moves the Z axis down closer to the board before setting the X-Y and this seems to resolve the problem.

Any thoughts or ideas.

1 Like

Hi William, It looks like your process flow and the point at which you’re homing might be the issue here.

Here’s the process flow as intended:
Power on CNC
The machine should be homed first.
Jogged into position for Z probing (I recommend probing directly atop the actual area to be carved and NOT far away at the front left corner of the board, you’ll get a more accurate Z by probing center of the carve area)
Then Probe for Z Zero.
Then jogged into position & set X,Y zero.
then start the carve per the on screen prompts

IF there’s a second or more bits used the process for that would be:
Swap Bit
Re-Home ( this extra Home cycle is usually not needed IF this modification is done to the settings: How to fix X-Carve Lock Motors Fault For Stress Free Bit Changes - YouTube )
Jog into position for Z probe
Jog back to the X,Y zero position (this jogging back to 0,0 can usually be skipped UNLESS there is a Drill operation exactly at 0,0),
Select “use last X,Y zero”

In this sequence note that the Home only occurrs before setting zeros and I think the discrepancy is that you’re homing after setting Z zero and that is the cause of the fault you’re experiencing.

1 Like

Thanks for the response. I will try the “Lock Motors Fault”. This is the reason we use the Home to set X&Y since we frequently bump the router in the X axis when changing the bit.

And I will use your suggested sequence: Home, jog to probe position, jog back to X&Y zero. But I am still confused as to why using Home after Probing changes the Z setting from the probe. After the Probe process, the Set X & Y form clearly indicates it is to set X & Y, while the Manual setting forms indicates you are setting X, Y, & Z to the current position. And another user in the shop said that he has discovered by lowering the router some random amount, the problem is resolved, which also makes no sense.

2 Likes

So what happens is after setting X,Y the next page has you “raise the bit” to the safe height and this command performed using incremental movement, meaning regardless of where the Z is located it will send the command to RAISE up the distance that the safety height is set to (be default this is 1/4")
Sooo using your method of Homing after setting Z this results in the axis crashing into the Top of the Z during this “raise the bit” step. This crash results in a loss of steps and now your Z thinks it is at a location that it is not at.

I bet this other person who is lowering it some random amount is lowering it at least 1/4" and that prevents the crash from occurring.

One thing to know, there are limit switches on the X-Carve BUT those are Only used for homing UNLESS the user changes their settings to turn them into crash sensors as well… but by default they are not set as crash sensors and when the cnc crashes it just looses position and no longer knows where exactly it is located.

Are you setting X,Y Zeros right at the home location?

1 Like

Seth, I am pretty sure that the RAISE command is exactly what is happening. And, yes, the manual lowering of the bit is definitely putting the Z axis low enough to prevent the crashing.

Yes, we generally use lower/left as our X/Y work zero / home position. However, with the new jog controls and carve from center, I am starting to use other location for home. I recently cut several 2" x 2" spacer blocks to position work exactly at X=2 & Y=2 so I can have better clamp positioning around the material. Then I can use 1 inch for the X/Y jog, go right 2 and up 2 to set home. I like to have an accurate/repeatable starting Home position, which is why we were using “home” as X/Y 0; the limit switches made that a repeatable position. However, now with the new jog & DRO controls anyplace can be repeatable if you keep track of where you start.

Thanks for all the help!

2 Likes

Seth, do you have more information about this feature? I’m keen to learn more

1 Like

You can set $20 to turn on soft limits which will prevent s crash before it happens by using the home position and the set work area of the machine. It will recognize when the next move would cause a crash and itll stop the machine

Youd need to open machine inspector to send this grbl setting change.

Press ctrl+shift+D to open this page then in the console are send this command:
$20=1

You can also scroll to the bottom and click the tiny refresh button and verify the setting change took…

Youd also want to be accustomed to checking this page for any time a job fails to complete and check if the status says alarm and check for the alarm number in the console area, alarm 1 and 2 indicate a limit fault (caused by an impending crash prevented by editing the above setting)… and other alarm numbers and a master list can be found googling “grbl alarm codes”…

2 Likes

fantastic! thank you

1 Like

Thanks for the info. Sounds good, but the idea of it stopping the carve if the move would crash doesn’t sound so good. I haven’t had that problem during a carve, it is more of a problem when manually moving on of the axis.

2 Likes

Hey William, I was really just trying to answer James’s question, didn’t expect you to implement this also,
unless you wanted to.

However since you brought up jogging, so long as the cnc is homed first. This limit setting will also effect jog moves to prevent crashes into the work area limits from manual jogging as well.

1 Like