Problems running first test carve. advice appreciated


I managed to build the XC and run through the various tests and everything seems in order. motor motors running and in the right directions, homing sequence, z probing etc all good.

Then I got to the test carve page in easel and it wouldn’t load.

Tried a few times and in the end decided to open easel and set up a simple design and run an air carve.

All seems fine running though the set up until I get to the ‘Almost ready to cut’ stage. The ‘Spindle is on’ and ‘Carve!’ boxes are greyed out and unclickable.

Anyone got any ideas what’s going on?

Many thanks

Mine done the same and I just unplugged the usb and put it back in. Worth a try. Also check your e stop button. Make sure it is fully depresssed

The E- Stop should be fully up not fully deressed…

1 Like

Thats what I meant. My bad.“Released”


I don’t think it’s the stop button. that seems fine.

i literally can’t click on ‘carve!’… its greyed out and not responsive.

it doesn’t seem to be a connection problem either cause i can jog it along an all the axis.

is it a setting thing?

I’m at a loss

Is the bit the correct size and type for the job ?

Thanks for weighting in. I’m completely head scratchingly stumped.

I’m doing an air cut as a first test and getting all the way through Easel intro with everything seeming to be responding fine.

I have an X-controller
power light is on
fan is running
Stop button is not depressed
XC jogs and homes in response to commands

Then when I get to the ‘Almost ready to cut’ page I can’t select the ‘spindle is on’ or ‘Carve!’ buttons

I am using a mac.

i must be missing something … could it be a settings issue, a software issue, a hardware issue?

thanks again

hi Robert.

i selcted manual spindle.

Couple of questions:
What browser are you using? I also use a MacBook Pro but have found Firefox to be a little finicky on a Mac so I always use Safari with Easel

Since you can jog the spindle(in all axis I assume) and home it, then it would not seem to be a USB issue.
Do you use Inventables Dust Control?
Do you use a Z Probe? Did you actually set your XYZ coordinates for your workpiece(not machine homing)?

So it looks like this is some kind of software problem.

I borrowed a pc running chrome and the air carve worked fine !! very happy with that.

in doing it i realised on the ‘almost ready to carve step’ there is a button to raise the bit that is not showing up on my machine.

the set up on my mac is:
Yosemite 10.10.3
Safari 8.0.5

I have support request with inventible so will let you know what they come back with.

Any suggestions in the mean time greatly appreciated.

Try it anyway, it won’t hurt. Press it down fully, twist hard while pulling up. This has gotten me more often then I care to admin.