Problems with "Intro to Easel" project, depth of cut and spindle power issues

I am in the middle of my first carve after assembling our 1000mm machine with a 24v spindle. The machine was mostly assembled by two of my students, both 12 years old, who have been hanging around my classroom this summer.

I have to comment that these two kids had very little difficulty in following the instructions and getting the machine put together. I completed the last part of the wiring and soldering of the motor driver board and the final electrical connection of the PS and controller to the machine. I found one small assembly error (the y-axis slides were upside down, easily corrected by just flipping over the homing switch to match the actuator), and corrected a reverse wiring of the right hand y-axis motor. I squared up the gantry, tightened up the dynamic v-wheels, and went over every nut and bolt for proper torque, but other than that, the kids did everything.

I am currently watching it cut the “Intro to Easel” project.

The only material I had handy for this was a piece of 1x4 pine I had jointed square and surfaced planed to a uniform thickness of .755 inches according to my digital calipers.

I have one problem I can’t seem to solve, and a comment about the “Intro to Easel” project that is more of a whine than a problem.

First, the problem, I have manual control of the spindle only. It powers on and off when I flip the spindle power switch on the PS, but it will not respond when I use the "logic setting.

I did a forum search before posting this and I hope someone has suggestions.

Second, here is the whine… I am disturbed at how deeply the machine is cutting this “intro to easel” project. Each pass is a reasonable depth of maybe 1/16" or so, but the outline of the little “chalk board” critter is ending up more than 1/2" deep. The machine is plunging so deep that the conical section where the shank of the bit tapers down to the spiral cutter is dragging against the surface edges of the outline, destroying the definition of the surface edges. The tutorial “walk through” of this intro project really needs to include instructions about how to modify the depth of cut, but also, it really shouldn’t be so deep. It only took 6 minutes for the machine to carve my name, but almost 45 minutes to cut out the little chalkboard and easel critter, just because it was so need. Waah!

Over all though, I really like the machine and impressed with what I have seen so far. I apologise for the whine, and would really appreciate some guidance on the spindle logic issue.


Some of these instructions may be a bit obvious…

  1. make sure switch is in logic
  2. in easel under the machine tab select spindle control and click automatic
  3. set rpm (“12000”) to test atleast
  4. run a sample

also for your whine when in easel try drag selecting the objects you want the depth changed on and click once selected. on the upper right you can change the slider to adjust depth!

any other questions feel free to shoot me a message or reply here.

Hi Nick, Thank you for responding. I’m pretty sure I tried all those things, but it was 11:00 last night, so when I go back to school (30 miles away) I’ll try again, but I think I was not clear about what I did try.

I ran the test/configure routine where I tested the motion of all the axes, the homing routine and so on. When I got to the spindle test routine, it asked me if I wanted to control the spindle manually or automatically. I chose automatic and as I recall, it prompted me to flip the toggle switch to logic, which I did. Then it prompted me to click an icon (button) to turn on the spindle, which I did, then it asked me if the spindle was running, yes or no, which it was not. When I clicked on the “no it’s not running”, it sent me to this forum.

The main thing is the spindle does run when I flip the toggle to “on”, so I can carve with the machine, but it appears that I cannot control the spindle with the software.

I did run across a thread here today that suggested that early on there were some problems with the control code that were causing the spindle to not respond to software commands properly. I didn’t have time to read for detail and I wont be able to get back to the machine until next week. But I wonder if the fact that I took delivery of the machine in May, but didn’t finish assembly until last night means my Arduino was flashed in April and is running an early version of that has a motor control problem. Maybe if I re-flash the Arduino, the problem will be solved…of course I have to figure out how to do that…

I appreciate your help with the whining too. But I found the solution in another thread and maybe it’s something you want to know about. I learned that Easel sets cutting depth as a proportion of the material thickness. The Intro to Easel project was designed for 1/4" ply and so the cuts were all shallow for that material. When I told the program that I was using 3/4" material, it scaled up the depth of cut by a factor of 3x. I should have just told it my material was 1/4" and assuming I homed out properly, I would have been fine.

Anyway, thanks again for responding. This is just about the smartest, most thoughtful, creative, generous, and helpful community I have ever encountered on the internet. If the community reflects the company, and I think it does, Inventables has years of success ahead of it.

as far as i know they do not use the arduino bootloader but if they use grbl it is pretty easy to update. i do not have my machine yet :frowning: so i cant be the most help but i imagine if you contact them via there support link on there website they will fix it for you in no time

Yeah, it was something about the version of grbl running on the Arduino, or a change that had to be made there. I’m trying to run it down right now, at the same time I’m trying to learn DraftSight for a class I am taking on laser fabrication. Probably I am crazy trying to learn three major new (CNC machining, Laser cutting and also trying to figure out how to use the same tool chain for both).


Found it, this thread here Spindle control from Easel

1 Like

I had the same issues, I had some 3/4" maple handy and had to abort when I saw how deep the easel guy’s (or gal?) hand went. I expected stuff like that to just be a slight inset regardless of material thickness.

I’ve also noticed it seems easel’s “home” position is not inclusive of the bit in X and Y. If I have a 6" x 12" piece and try to surface it with a 6x12 square and a 1/4" bit I have a 1/4" margin on the left and bottom when I home the bit to the lower left corner. Now that I know, I can adjust, but that’s not very logical at all.