Spindle control from Easel

Update This feature was deployed April 24th, a week early! You now can select “manual” or “automatic” spindle control from the “Machine” menu and it will add M3 / M5 with spindle speed to your gcode. Please let us know if you have any feedback on the new feature!

##Feature description

Those who have purchased the spindle speed controller for controlling their spindle (and future x-carve customers) are not able to turn on their spindle using a switch, so the standard walkthrough fails for them:

Before the end of April, when X-Carve starts shipping.

  • Assumption: We can know on a per-user basis whether they can control their machine using M3 / M5 gcode commands.
  • skip the “turn on spindle” step of the walkthrough
  • put M3 / M5 into the g-code header / footer
  • (not just in walkthrough because we want the spindle commands to be in exported gcode)

###Scenarios to consider:

  • job is cut short using the “stop” command
  • “stop” command should turn off the spindle
  • job is cut short and machine connection is lost
  • put “spindle on” / “spindle off” in the machine controls panel because spindle control may be out of sync safety message that instructs users that their spindle may still be running?
  • grbl 0.8 vs grbl 0.9, is there any difference in spindle control?
  • controlling spindle via PWM (i.e. setting spindle speed?)
  • A persons machine is in constant flux, the machines capabilities (like spindle control) are not set in stone and they will change in the future. How to update the machines capabilities?

We are working on this feature now. It’ll introduce a couple of new settings

Spindle Control: <automatic, manual> 
Spindle RPM: <number>

There are two places where the spindle control / rpm comes in to play:

  1. The gcode (downloaded and sent to the machine) will have an M3 S[rpm] command at the top after raising to the safety height and an M5 at the end after raising to the safety height.
  2. The walkthrough step before starting your job where you “raise the bit” will also send an M3 S[rpm] command, and you have the same “confirm the spindle is on” step. This is to add an extra check that your spindle is working before starting the job.

Question: Does anyone ever need M3 without the spindle rpm? Does sending a default RPM negatively affect any setup?

This feature was deployed today, April 24th. See the update to the top post!

Q1 - Will Easel populate the Spindle RPM entry field (on the Machine data form) based on the material/tool selected? Or will the user be required to determine the correct/optimum RPM based on their years of experience (or wild guess in my case)?

Q2 - If the power supply is powered off (emergency stopped). Will the 24V spindle start spinning when power is restored?

Q3 - If rough/detail tooling is selected is there an opportunity for the user to change RPM with the tool change?

I am mostly worried that this is another variable that I don’t fully understand and will set incorrectly. Much like feed rate, plunge speed ,) Can we just set the spindle speed to 80% and get mostly reasonable results? Much like I have learned that there are “safe feed rates” that won’t break the machine or end mill. I may not be using the optimum feed rate but it is safe feed rate…

Hi, I am new to this forum :slight_smile: I have just read this page regarding the control of the spindle speed, I didnt quite understand all of it, to clarify; is the ability to set the speed standard on the X-carve? or do I need to purchase any add-on? I would like to be able to slow it down to about 200 rpm, is that possible? thank you

If you purchase the DC spindle and power supply from the X-Carve configuration page then yes you get spindle speed control included (note: it does require soldering).

@BartDring would be better at answering the minimum RPM question.

@Korimako The speed control has no lower limit.

The speed control is done via PWM, which is basically voltage control. This means it looses power as you lower the speed. The power will be unacceptable at speeds that low.

It is also not closed loop. This means there is no feedback to the controller of the actual speed. When the spindle encounters the load of cutting, it will slow down.

What are you trying to do at that speed? Maybe there is an alternative.

Is it only me that is not seeing the spindle come on when I select “use last home position”?

I have the same problem, but I thought it was just buggy because of the 2-Stage cut version… We should probably post this as a new thread…

edit: or maybe not. there isn’t an Easel > Troubleshooting section or bug reports section

1 Like

Thank you for your reply, would it be feasible then to adjust the desired speed in easel and watch the actual speed relative to the load and then re-adjust from easel until I reach a desired speed? thank you

There is no speed sensor, so there is no way to give you speed information. You also cannot adjust the speed once the job is running.

I purchased the 24V spindle and power supply with the upgrade kit. Following the instructions I connected the spindle to the + and - spindle connectors on the PS header. I don’t have any speed control and the only way I can control the spindle spinning in by flipping the spindle switch to full up position, the Auto (middle position) just turns it off.

So there must be some other instructions somewhere else that I missed to provide auto on/off and speed control. Or I have misunderstood and just need to keep turning it on and off manually?

The middle position is off. When the switch is down it is in auto, and Easel will control the speed and turn it on and off.

But I think you will need to re-run set up with it in the auto position to get it to see that it is set there. Maybe not, but if it still is not working try that too!

@sketch42 - Yes you are correct, down is Auto, but it still functions as Off for me. Obviously I need a control signal from the Grbl, but I missed the instructions for how to wire that. Is there a link to the steps need to wire the spindle control logic from the Grbl to the Power Supply?

This is a bug. It is unrelated to the 2 stage cuts feature.

Do note, however, that if you proceed with carving the spindle will turn on. I have done it, and it is scary, but it works.

The bug fix will be coming.



@AllenMassey, check out step 13 in the Electronics section of the instructions… did you wire the bit with the yellow and black twisted wire?


@sketch42 - No - I saw that step, but my kit did not include the Header Crimp Connector so I was not sure what to do for that step, I assume that I need a logic connection from the Grbl to the Power Supply, but the step does not really give any details about where on the Grbl I should make that connection,