Putting GRBL onto an X-Controller

I have an X-Controller and am trying to put GRBL on it. However; I have searched and searched and cannot find a way to put GRBL on it. I have downloaded GRBL 1.1 I believe was the version; but I cannot find a way to move GRBL onto the X-Controller. I am using Easel for projects and I would like to use GRBL to progress my machine but I got this info from Griffin Dennis: for 8x microstepping I’d need a setting of 400, 320, 640 steps/mm for the X, Y and Z axis’ respectively… Now that being said I have 2 issues to put it simply.

  1. How the heck do I get GRBL put onto my x-controller as I can’t figure out how to upload it and I even tried XLoader but I can’t find the file I need to load.

  2. Once I get it loaded onto the X-Controller how do I change my stepper settings?

If anyone could help it would sure be appreciated because I’m about to pull my hair out trying to figure this out.

Ok I think I finally figured out how to get GRBL on my X-Controller using XLoader. I uploaded a file I found and it gave me an output of 30492 bytes uploaded… however; Now that that’s done. How do I change the step settings as I stated above? Also I’m using Easel to do my projects so would this change the machine configuration I have set up? Any help is appreciated.

Did you use the inventables fork from here? -> https://github.com/inventables/grbl If you did, I think most of the settings are the same unless you updated them prior to installing the latest one.

For updating the settings, use Easel’s machine inspector or UGS

grbl settings here-

Alvin,

This is the file grbl_v1.1f.20170801.hex I downloaded and I did get it from GitHub. However; its the only file I uploaded. and looking at the GRBL settings you sent I just can’t see where to find the G prompt to look at the settings and get them set. What program do I use. I know it says set the baud rate and all but using Easel I don’t see that at all. Or maybe I’m missing it.

This is really OS dependant. Are you using windows? Mac? Linux? did you try to upload GRBL through Easel with the official version? are you trying to upload a generic GRBL or a version from someone else? do you have the hex file (i.e. 1.1f.hex) or do you have a un-compiled version from the github site? I know these are a lot of questions but really they are important.

I want to assume you are using windows and the official Easel version is not the version you want to flash.
when you flash your hex file with Xloader and see the completion screen you can start any controller program such as Easel or UGS and issue the $$ command from the command line. this will print out on screen all of your parameters. from that same command line you can issue any changes you like (ex. $31=1) will change the value of 31 from 0 to 1

1 Like

In Easel go to “Machine” at the top menu and on the drop down choose advanced. a new window will appear and then choose “machine inspector” at the bottom. this will open a new windows with the console.

ok thanks that helps however; what settings are the x y and z axis? I see a list of settings like $131 etc…

Sorry I think I found it looks like $100 and 101 and 102 for x,y,z respectively! thanks all I’ll attempt this

Your steps/mm are WAY off if you’re using an Xcarve.