Quick tip to not break bits in Chilipeppr

So it was my first time milling a PCB- about to get started with probing. So excited. I click “run test probe.” It descends so slowly and stops PERFECTLY at the pcb. I’m like, “awesome. Let’s get to probing the whole thing.” I click “run auto-probe” and my machine jams the bit into the PCB, crushing the bit and cutting deeply into the copper. I’d never zeroed my machine. The clearence Z value was 1.5mm, but Chilippepr believed that, after running a test probe, my bit was at Z = 25mm or so. So, down it went! And hard. So, learn from my mistake. Don’t be hasty. Watch the tutorial videos before you start clicking stuff.


Ive made a similar mistake with cutting bits more than once in my haste to get the motors a’steppin.

I have pretty much trained myself to slowdown and double check things before I press “send”

I also have my hand on the kill switch when I send the file just in case.

1 Like

I noticed this too, and it could be solved by a change to the chilipeppr autolevel UI. There is one setting for “clearance Z” which is used for all autolevel attempts. It defaults to a low number (1.5mm) which is almost guaranteed to destroy a bit if you don’t adjust it or set Z zero first. But if you set this value to something safe/reasonable (5mm) for the first try, it takes forever to autolevel because this 5mm clearance value is used for all subsequent tries.

The UI should have a setting for “first Z clearance”, which could default to something safe. Then, after this runs and sets Z zero, a lower clearance value could be used for subsequent points.

Until then, the safest thing to do is go through a checklist:

  1. Home the machine
  2. Move to PCB lower left with Z at the top axis limit (I store this in G28)
  3. Move down to about 5mm above the PCB using manual axis controls
  4. Run a test probe to find zero Z
  5. When it stops, zero out Z
  6. Move back up 10mm Z using manual axis controls
  7. Start autolevel job

It’s not a great experience, but Chilipeppr is free and very functional, so I’ll just be happy with that!

1 Like

Interesting feedback guys. I didn’t realize this was happening to folks. I’m not sure I’ll get around to any fix soon though, but I’m always up for folks taking a crack at the Javascript and seeing if they could add that extra step either after the test probe to raise the spindle back up or to double check before starting a job run. It’s really easy to fork the code to see if you can add/tweak features and then I’m very happy to make those changes get placed in the mainstream ChiliPeppr.


1 Like

I just broke two more bits.

You’re clicking Z down at 0.1 speed because you really don’t want to break that bit. You accidentally click the “custom” button, which is preset at 10, and is right next to Z down, and then the z down once more. It’s all over.

You decide that, instead of working it down slowly manually, you’d just set it for auto probe and let it zero itself. That works great, so you’re ready to home it. But hey, the coordinates window at the top of the page is off the window, you’ve gotta scroll up. OH- the little “jogging pad” area just under the coordinates information interprets your scroll up as a command to quickly move the Y axis- another bit down.

Go slow. SO SLOW.