Inventables Community Forum

Raise Bit is moving Z to max Height - Carving Air (HELP)

Hey Guys,

Day 1 of actually carving on our new X-Carve Pro. I’ve been testing different materials with a simple star shape carve. So exciting and for a few hours everything worked great but randomly something changed and now when I zero the bit and click “raise bit”, it raises too far, now its moving to Max Z height every time and tries to carve 4 or so inches above the material (its carving air). Does anyone know how to fix this?

I’ve tried switching browsers, restarting the X-Carve, every attempt gets worse and I’m afraid of trying again.

Can you check your GRBL settings and post them here? I do not have an X-Carve Pro, but I know there have been issues where $1 is not set to 255, and in my opinion, $1 should always be set to 255. There are some other possible changes to the acceleration setting for the Z-Axis that might need to be updated (not currently approved by Inventables), but let’s just start with $1 for starters.

To retrieve your GRBL settings via Easel, do the following:

  1. Go to Machine>General Settings>Machine Inspector

  1. Type in “$$” and press Enter to get the GRBL Settings returned from the controller.
  2. Copy the settings that are returned and check $1 or post them here.

To set $1 to 255, type in “$1=255” into the Console text box and hit enter.

The $1 setting is the Step Idle Delay. Setting it to 255 forces GRBL to provide full current to the stepper motors when they are idle (i.e. not in motion).

Rehome the machine afterwards and then try it after that.

{:0)

Brandon Parker

Hi Brandon,
Thanks for the help! Appears $1 is set to 255 already, any other possible causes?

  • $132=130.000
  • $131=1219.000
  • $130=1219.000
  • $122=500.000
  • $121=350.000
  • $120=250.000
  • $112=2540.000
  • $111=7620.000
  • $110=7620.000
  • $102=160.000
  • $101=42.353
  • $100=42.353
  • $32=0
  • $31=0
  • $30=24000
  • $27=2.000
  • $26=250
  • $25=750.000
  • $24=25.000
  • $23=3
  • $22=1
  • $21=0
  • $20=0
  • $13=0
  • $12=0.002
  • $11=0.020
  • $10=115
  • $6=0
  • $5=0
  • $4=0
  • $3=14
  • $2=0
  • $1=255
  • $0=10
  • [echo: $$]

Have you checked your “Safety Height” and “Origin Safety Height” yet? Typically both are set to 0.125", at least for a regular X-Carve.

Other than that, if your Z-Axis is losing steps, it might be that the motor is stalling. I know that some people have had success in preventing this on the X-Carve Pro by changing $122 from 500 to 100. This lowers the acceleration rate that GRBL attempts with the Z-Axis.

I would check that you did not inadvertently change the safety heights before moving forward with anything else.

Also, is it doing this consistently? Is it doing it after a complete power cycle?

{:0)

Brandon Parker

Hi Brandon,

I decided to try the Probe method and it’s working now. I will check the other settings once the carve is complete and report back, previous was all manual zero as I was afraid to try probe after what was happening. VERY HAPPY RIGHT NOW :smiley:

It was consistent w/ full power off and on.

1 Like

Ok, that kind of makes more sense now. Maybe you were not actually telling Easel to redo the Z-Home position with your previous manual process.

Probing is always the best way to go.

I would not worry about any settings at this point if everything is working for you.

{:0)

Brandon Parker

Just an idea… Maybe the manual setting should be removed if it doesn’t function properly. Not every new user is going to know the manual option has a major programming bug.

I am unaware of a programming bug in Easel’s process for zeroing…

{:0)

Brandon Parker

1 Like

There’s one bug that I reported months ago and never got a ticket closure report… it only comes in for custom thickness z probes, and there are like 6 ways to cause the custom thickness to reset to 14.99 (the inventables probes thickness) and the only way one would know is if machine inspector is checked after probing and then moving the v back down to the workpiece surface… then you could be able to tell that your custom thickness had been erased… other than this bug with regard to custom thickness probes, I also have not seen any other zeroing bugs…

I’ve seen z axises dropping by not setting $1 to 255 and having too heavy of a spindle and then gravity will pull the z down, out of the desired position… but this isn’t a zeroing issues so much as a grbl setting issue…