Random stops during cutting - tried all the usual suspects [Resolved]

Hello all,

I know this topic has come up a few times, but i have tried all of the solutions i could find on the forums.

So have a X-Carve 750 (slightly more rigid than the 1000 so chose it for aluminum, have a 1000 for carbon fibre which seems to be working fine with stock dewalt router).

It is stopping at random points whilst cutting, sometimes after a few seconds, some times seconds before its about to finish, and occasionally gets all the way through.

I upgraded with a 2.2kw water cooled spindle and VFD. I have a upgraded z axis and stiffening supports on the way, but not using currently.

Im using UGS after doing CAM in fusion. When the error happens, the PC reports the USB device as malfunctioning.

A few things i have noticed, and not sure if they are connected:

  • When it looses USB connection, it seems like the Y axis is pulsing, maybe 5-7 times or so
  • May be coincidence but seems sometimes if i even touch the work area it stops
  • But other times i can grab the rails with force and it still keeps going.
  • The z axis, when lowering the spindle, makes the machine vibrate, is fine when its going upwards though, and manually moving it, this is only during a cut.

It runs fine and doesn’t stop if i zero it to few cms above the material and run the spindle. So the only thing not happening is cutting material, it runs fine like this. But, when its actively cutting material is when it will cut out.

As a side note, the spindle is happily eating through the aluminum, no chattering etc, very clean cut.

What i have tried:

  • UPS
  • Shielded USB, and grounded
  • Moving the VFD, moving the PC
  • Powered USB hub
  • A Different PC and laptop
  • Easel, UGS, old and new stable and beta
  • Running VFD on the next buildings power circuit (literally via long extension lead)
  • Running a program with it not in contact with material
  • Slightly increasing the pots

What im curious about:

  • Due to the heavier spindle do the pots need to be changed?
  • Could this be something to do with heavier spindle? But then why so random?
  • As above i have tried almost every suggestion from the forums, could it be a fault?
  • Could belt tension, or adjustable wheel tightness actually cause the problem of cutouts?
  • Could vibrations cause this?
  • Is there some kind of feature that if the machine is struggling it send a stop command, but how would that manifest via UGS as a USB malfunction?

Hopefully someone has an idea i haven’t tried. Thanks

EDIT: Seems to be resolved now after re-seating the ribbon cable for the USB front panel module. It was out by 0.5mm. Since making sure this was seated well, its running fine.

Although the locks where engaged on the ribbon cable clamp, there was still some distance the connector could be pushed down.

Is this happening with one particular file OR does it seem to do it on all g-code files?

It’s doing it on all gcode files, and also wether it’s in easel, ugs etc also variations of gcode such as different speeds and feeds, it still does it.

Have you tried a direct USB to mini USB cable between your computer and the circuit board inside your X-Controller? I found with my setup that when eliminated the short cable on the front panel of the box and the circuit board these sorts of problems disappeared.

This action solved things for me, too.

Yes had tried USB to the main mini usb port inside the box, no luck.

As a side note, this morning i tried grounding more parts of the frame, spindle, material etc. This actual resulted in not being able to start any gcode, but i could jog the machine. Strange.

BUT - A bigger update, is in desperation, i took the x-controller from our new 1000mm, and plugged it into this machine, and low and behold its completed about 10 cuts in a row without issue. So im quietly confident it was a faulty X-Controller.

More interestingly, this is even without all the grounding, and extra measures. So it seems there is potential that not all X-Controllers are equal in terms of RF resistance. Will keep this updated.

Starting to sound like the power supply module, maybe not the controller module. Acting like your loosing one side of the ground. Maybe a loose connection in the power supply module.

Same type of issues, so watching this thread. The X controller shouldn’t be this sensitive to EMI. I have stopped using ours at eh MakerHive, to unreliable and wastes to much time. I tried one last time this past Saturday, ate up 2 hours and finally set up a jig and used a router by hand. Very expensive product for the issues it has.

Ok, so thank you to Chris, and everyone.

Went over all the connectors, and one of the ribbon cables wasn’t quite seated (USB one). Although, it was probably less than 0.5mm up on one side of the ribbon cable connector.

Re-seating that, its now running absolutely fine. So im thinking loose connector made a partial ground, with intermittent disconnections. Or the actual signal cable during certain vibrations, would stop the connection.

But fingers crossed, it all seems resolved now.