Rapid Speeds Adjust

I just upgraded my Xcarve with xcontroller to direct drive ball screws and calibrated the axis. Now it is trying to do rapids too quickly and overworking the steppers. Is there a way to adjust the max speeds?

$110, $111, $112 for X,Y, and Z respectively.

What ballscrews?

Thanks NeilFerreri1, that worked perfectly! I appreciate the help.

The machine is running now but is losing steps on direction changes if run too fast. Would stronger steppers help this problem or can I adjust the acceleration?

$120, $121, $122

What ballscrews?

What are your values?
You shouldn’t be losing steps. Does everything move smoothly by hand?

Everything is very smooth by hand.

$0=10
$1=255
$2=0
$3=7
$4=0
$5=0
$6=0
$10=115
$11=1000.000
$12=0.002
$13=0
$20=0
$21=0
$22=1
$23=3
$24=25.000
$25=1000.000
$26=250
$27=1.000
$30=1
$31=0
$32=1
$100=320.000
$101=160.000
$102=49.909
$110=1000.000
$111=1000.000
$112=1000.000
$120=4000.000
$121=4000.000
$122=50.000
$130=750.000
$131=750.000
$132=100.000

I guess this is one of the disadvantages of not buying a kit but I could only find lead screw kits and not ball screws. Thought it would be a simple thing designing the plates and slapping some screws in it. I’ve found by playing with the values I can make it not lose steps but then it seems slower than it should be. Higher than 100ipm is when it starts losing steps.

Drop those accelerations way down. Try 500.

Yeah, accelleration is too high. Try 500 as Neil suggested.

FWIW I use 1605 ballscrews too (with 269oz Nema23’s and 48V PSU voltage) and I have my rapids at 3500 and accelleration to 750 for X & Y.

Update, Thanks for all the help guys, my acceleration was much too high. I adjusted that and it was still losing steps though. I adjusted the cornering speed ($11) down to .002 and it will run at 200ipm now without losing steps. It would run flat out in either direction without any trouble but as soon as I would start a carve and it would make that first turn, the Y motor would stall.

That is borderline.
A plain stepper dont push much past 1000rpm and with 1605screws 200IPM=1000rpm required.
There simply wont be much useful torque left at that speed. A stepper loose torque at speed and eventually 100% of the torque is required to just keep it moving.

Set max rapid to 3500 for X/Y and you’ll be at a much more suited spot, you’ll have an extra torque reserve for cutting forces :slight_smile:

Thanks, I did that. I appreciate the help. It seems to be doing well but I’ll continue to monitor.X-Carve Ball Screw Upgrade First 3D Carve - YouTube

Where can I get a printout of these settings so I set mine up properly?

I’m at work now but will pull up the current settings when I get home and post them. You can access them through advanced machine settings in easel.

Yes, the advance machine settings. I would like to check to see if they are all set to what they should be? Do you have the correct settings they should be? Thank you.