Really need some advice with Aspire

I am new to both Inventables and to CNC. Just bought a Chinese router from eBay, and I think it is finally ready to cut something. When I create a project (a 2D sign that has pocket holes) in Aspire, I set the material size to 10" by 20" and I assumed that it would cut at that size, so I had a piece of lumber a little bigger than that on the bed, but what it actually does when I run an air-cut test is significantly smaller than that. Can anyone give me an idea as to why that is? I may have made an error in getting aspire, as it is way over my head for learning on, but I figured if I was going to spend money, I might as well make it worth my while…

Smaller? Are your units set to millimeters?

No, it is set for inches.

There are TONS of tutorial videos offered by vectric which will help you learn the program side of things.

Being that you got a cheap CNC on ebay, have you calibrated it correctly and done any test carves?

I’m sure more knowledgeable people will chime in.

It was very difficult to set the CNC up. The manual was 1/2 in Chinese, the rest in broken English. That was bad enough, but worse was the fact that the settings given in the manual were wrong, and the seller repeatedly provided the same wrong settings. Also, the VFD settings for the spindle had to be adjusted, and no manual was provided for that, so there was no clue how to accomplish that. CNC groups on Facebook and folks at the CNCZONE forum were very helpful in getting that all sorted. No test carves have been done at this point. I am thinking of setting something up in Easel and trying that.

Originally, the steps were done in inches, but beings I was inputting the incorrect settings given by both the manual and the seller, I had to redo it several times until I figured out what was going on. Perhaps I have that wrong now? I will double check that in the mach 3 software. And it is set to jog off the PC keyboard. I do not know how to specifically jog it a set distance.

No, I mean that when I was doing the motor output settings under ports and pins. Every time I was redoing those to try to get it to work, I just redid the entire settings shi-bang, and thought maybe I had redone it in mm. But I just checked, and it is in inches. Thanks for the tip on those instructions. I have to try to find those because that is certainly something I want to make sure is right.

1 Like

What type of controller does it use? Is this similar to the X-Carve (arduino based) or other. Maybe you can include a link to your machine. This might provide more insight.

I do not know a lot about these machines yet, but I was told on a CNC group after telling them what I have that this is not a GRBL based unit. Here is a link to an ebay page with a unit like the one I have.

PM sent

I have not yet been to the Vectric forums, I am not really sure I will need to go there, as I am beginning to believe that I just do not have the steps per inch set correctly. As of this time, I have not been able to find the post that was mentioned earlier in this thread regarding setting the steps per inch. As for a forum for the router that I have, because I got it from China and I have already had ridiculous problems like with the manual not having the correct settings and even the seller could not help me out, I highly doubt there is a forum for this particular brand of router. The manual has the name DONGDA on it. I have contacted others with this same unit on the CNCZONE forum, and have approached them for help setting the steps per inch.

Finally got the steps per inch set at what I am pretty sure is right, and now it looks like the size it is air cutting is more of what it should be.But when I tried a test cut, it started out OK, but it was not long at all til the bit stopped and the axes kept moving, and the bit snapped. Not sure why, I am thinking the speeds and feeds are probably not right. But I’ll get it! Thanks to everyone who took the time to offer me advice!

Yepper it does. If he is using Mach3 then he needs to make sure that Aspire is generating the codes for Mach3 Inch mode. It really sounds like he is using Mach3 mm mode and a drawing of inches. That would make perfect sense.

yep, it’s a Mach3 machine:

Control box parameters:

Operating Voltage AC110V

Control unit Toroidal transformer + PWM power supply module + TB6560 stepping motor drive

Computer connection Parallel port

Command code G code

Acceptable software Mach3,EMC2

Protection Emergency stop button

If you go on the "settins " screen there is a small click on just above the reset that you should use to set your final settings.