[Resolved] Computer does not see Arduino

Here is something simple. Windows 10, with fancy sound alerts. When you plug anything to USB ports it dings low to high 2 dings. If you don’t hear that, there is no reason to install Arduino driver. Besides every time re-installing it, opens another Com port. (Mine is on Com11, before I realized). In that case, you have to go with EarWigger’s steps. Take your Arduino, connect another computer, if that Computer dings, rule out Arduino, work on Laptop ports.

When you plug it in usually, while watching your device manager, it refreshes the view adding in the new device. The trick is to find where it is being added. I would open the Ports (COM & LPT) branch and then plug in the arduino. Something new should show up there… At least hopefully.

OK, I went to Microsoft Management Console 3.0 -Device Manager - device Management and Installation and now at least have Ports and Ardunio Uno (Com3) showing up now. Still has an “!” on it and says it cannot start but at least it’s there now. We are making progress and I do appreciate everyone’s help. OK what I said above is not quite right I went to Device Manager - Action - Add Legacy Hardware. I picked Ardunio from the list and followed the screens. them the port showed up. Sorry for the confusion.

1 Like

I still have

This device cannot start. (Code 10)

The specified request is not a valid operation for the target device

I have tried to update the drivers and is says drivers are up to date.

Try uninstalling that device, (disconnect USB cables). restart your computer and insert USB cable one more time. If it is same condition again, you may want to go to HP.com and upgrade your USB device drivers. Also you can check USB port problems FAQ on same site.

Here is a link from the arduino community around device cannot start. http://forum.arduino.cc/index.php?topic=121781.0
I would restart your computer and see if the arduino is still under comm ports. If it is I would select update driver and from there manually install the arduino driver. It is in the c:\program files\arduino folder and not the USB driver folder.

All USB drivers are up to date.

Have you installed the arduino drivers…not the USB drivers? Keith in the post above explains how.

I’m working on it but I’m not getting something right. I am pretty sure it is the settings on my computer but this is the only one I have and I live out in rural America with no one to borrow one from to try a different one.
I will let you know haw it turns out. Thanks

Good luck…this explains the process.

https://www.arduino.cc/en/Guide/Windows#toc4

Thank you. It will probably be tomorrow before I can get back on this. Thanks everyone for your help.

Ok I uninstalled and unplugged everything and downloaded the Windows ZIP file for non admin install and started over. Plugged everything back in and it still did not show up. Got a little upset and started taking the gshield off of the Arduino and soon as I did my port came back. Plugged the gshield back in and it works. So after multiple computer problems and a lot of help from you guys I am up an running. Thanks so much you guys are wonderful.

1 Like

It is easy to plug the gshield into the arduino hitting the wrong connections. That might have been the problem. Glad it is working now.

Might have been. Thanks for your help

Just been there as well after a new build - blue light but no Arduino in Device manager in Windows 10 laptop. Tried 4 different usb leads etc. etc. Added Arduino manually and got it with exclamation mark triangle on Com 3 - progress of sorts. Then relocated G shield - tip first left hand hole and matching pin level with side cutout in housing as difficult to see pins and holes for insertion - and now not only blue light but three green ones and an extra Serial Device on Com 4 in Device Manager and “it lives!”

1 Like

Hello VickiLynnSomers I also having same problem, did not see arduino port on device manager… what is mean by gsheild

Did you get your problem resolved. My Arduino was plugged in one pin off. Once this was corrected everything was fine.

Hi VickiLynnSomers
I have the same problem you had and I still can’t solve it.
Can you tell me the exact steps you did to make the PC recognise the arduino…
And i don’t understand the term “G Shield” what does that mean ???

Thankn in advance for your help :slight_smile:

hey how did you solve your problem. I have 2 arduinos both got the same problem. LED 13 is continuously on. No problem in USB cable. I changed atmega chip for 1 of them and the led is blinking 3 times when I reset or plugs in, but still not showing in device manager. Please help solve this problem

What operating system are you running? Windows 10? I do not use the Arduino, but when I did mine was plugged into the G-Shield wrong.