[Resolved] GRBL flash and X-Carve settings

I spoke with Jeff last night and it seems that I ended up with an Arduino that did not have GRBL flashed onto it. He gave me the link to “compiling GRBL” which I have followed but it flashed GRBL 0.9i which I don’t think is the correct version as some of the pins are placed differently for limit switches. Also, the X-carve settings obviously aren’t preloaded so jogging in easel is… rough. Also, the y axis moves forward whether I press the up or down key in easel. I was wondering if I could get the exact GRBL zip file used to flash to the x-carve, and/or the settings accessed through $$. Thank you!

These are my settings in default GRBL 0.9i If somebody wouldn’t mind sharing a screenshot of their correct settings. Thanks

If they’re the same as the SO2: http://www.shapeoko.com/wiki/index.php/Grbl#Shapeoko_2_Hex_File

Thanks Will. I did give those settings a shot and also tried uploading 0.9g and 0.9i with the shapeoko 2 defaults. The machine didn’t move at all with the former and the latter still had the same problem with rough jogging on the Y axis as well as it only moving forward whether I try to jog forward or backwards. I don’t think its a wiring problem as I have compared it to the instructions, and both Y axis motors are spinning towards the same direction (forward only).

Hi Calvin,

I flashed the default grbl 9i to my own arduino myself, except for one change to override the max spindle RPM. I can operate my x-carve normally. I actually had an issue once when first setting my machine up where it would move the same direction no matter whether I tried to jog left or right. I also had an issue where it wouldn’t jog at all. In both cases going over my wiring and making sure the gshield was securely attached to the arduino solved those problems.

I’m not sure what could be accounting for rough jogging. Are you sure both motors are driving? I had an issue in the beginning where only one motor was driving. It was a wiring issue. You might also want to check your belting to make sure the pulleys aren’t slipping.

Jeff

Oh, after flashing you should go to http://easel.inventables.com/setup to set the correct Z step rate and to set it up for automatic spindle control and homing.

That did the trick! The Gshield wasn’t staying pressed down into the Arduino. I put a block in there to hold it down and it jogs in all the correct directions, thanks! Jogging on the x and the y axis still seems to be sluggish and produces a low grumbling noise. I will try tightening the belts tomorrow and see if that does the trick because the Z axis moves smoothly and the only difference is in belt tension. How tight is too tight?

Hmm. Sluggish and a low grumbling noise does not sound good. I’m not sure that sounds like loose belts, but I’m not sure what it could be either. If you power off the motors can you smoothly push the machine in the x and y directions with your hands?

Also not sure about the “block” on your gshield. Are you sure that’s necessary once you’ve gotten it securely attached?

Jeff

With the machine off, I can push them but there is resistance. The block is just a small piece of wood that sits on the edge of the shield. Temporary until I find a solution. The shield pins seem to fit loosely and unevenly in the arduino and gets pushed up and out on one side without some sort of downward pressure. I will record a video of the xy movement

Strange sounds in the motors are usually a bad connection, or damaged / defective stepper driver chip.

Power down, check the connections.

IMG_4498.MOV (1.1 MB)

I’ve checked the cables running from the gantry to the stepper motor and all seems to be fine. If it is a defective stepper unit, would it be possible to one of the axes would still be running fine? The z motor seems to perform smoothly

Standard way to check a stepper driver is to swap connections between motors.

Will, I just tried swapping connections. X and Y run smoothly when I put them into the Z output. Z was the only one running smoothly. When I connect Z to the X or the Y outputs, it exhibits the same sluggish behavior as shown in the video

Also here is a video of Y connected to the working output (z). I tried disconnecting the belts just to be sure both Y motors we’re spinning towards the same direction. I’m not sure if this is a belt tension issue? The belts don’t appear to be slipping close up, but it doesn’t sound good. trim.BF67763E-DC2C-4E45-B6F0-60409FAE37BE.MOV (4.4 MB)

It doesn’t sound right that your gshield won’t fit snugly into your arduino. I wonder if that is causing some of these issues.

I have checked to make sure that all the pins are aligned and that none of them are bent, but it still doesn’t feel like a snug fit, mainly on one side. I have also tried jogging while applying pressure by hand and I still get the rough jogging.

If it does turn out to be a defective stepper driver, would I go through inventables or synthetos for a warranty replacement? And if it is through inventables, would I have to wait for all the preorders to ship before my replacement goes out?

Hi Calvin,

You can email help at inventables. We can get you replacements if that is what you need. You won’t have to wait for all the preorders to ship.

Jeff

Thanks Jeff. I will email the team and figure out what the best solution is. I really appreciate all your help!