(Resolved) Issues configuring 1000mm X Carve grbl settings

Hello all. OK so I finally got my x carve together. I have been testing it with no spindle, just to make sure everything is wired and works properly. I have since run in to a couple issues which I believe are mostly software based. The first issue I had was when sending the test carve from easel to the x carve, it would just run from home to the opposite corner before smashing in to the makerslide. I believe I have corrected this by changing $100 and $101 from 250 to 40. This however caused the x carve to move super slow. I think I have kind of sorted that out by changing $120 and $121 to 200 and $123 to 25. Now however I am left with two issues. The first is the y axis seems like it moves so fast between cutting stages that something slips and I hear an awful grinding sound and it skips steps. The sound doesn’t appear to be a belt slipping. It sounds metallic, almost like a vwheel is binding and dragging on the slide. The second issue is even if I enlarge the material and carving in easel the x carve seems to want to stay in the homing corner and carve the original sized image. It doesn’t seem to be moving to the correct spot on the work space. Its almost like it cant tell where on the work space it is. Any thoughts on settings? Thanks in advance. I’m really looking forward to getting this working.

Take a look at this:

Hey @RickPeterson, sorry to hear you’re having problems.

When you turn the acceleration up, you also need to turn the potentiometer up as well (but this doesn’t always fix it). The reason you are hearing grinding noises is because the motor either isn’t powerful enough to accelerate that fast or the pot isn’t high enough. The grinding noise is the motor stalling. Assuming you have NEMA23s, you won’t be able to turn the acceleration up much past the stock 50mm/s^2

As for the homing issue, the (0,0) position in Easel is the position you zero your bit at, not the position of the entire work area. If thats not the issue, feel free to post the project here so we can take a look at it, or you can message me the link.

Let me know if you get this issue fixed!

Thanks for the tips. I am using NEMA 23s at 270oz. I know the gShield cant fully power them. I can’t figure out what settings got screwy and made the x carve go so slow. Turing the pots up helped a lot but still not quite enough. Here are my grbl settings if anyone could tell me what I need to change. The other problem with it carving in the wrong spot seems to have went away for now.

Grbl 0.9j [’$’ for help]
[’$H’|’$X’ to unlock]
$0=10 (step pulse, usec)
$1=25 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=3 (dir port invert mask:00000011)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.010 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=1 (homing cycle, bool)
$23=3 (homing dir invert mask:00000011)
$24=25.000 (homing feed, mm/min)
$25=500.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$100=40.000 (x, step/mm)
$101=40.000 (y, step/mm)
$102=188.976 (z, step/mm)
$110=8000.000 (x max rate, mm/min)
$111=8000.000 (y max rate, mm/min)
$112=500.000 (z max rate, mm/min)
$120=200.000 (x accel, mm/sec^2)
$121=200.000 (y accel, mm/sec^2)
$122=25.000 (z accel, mm/sec^2)
$130=790.000 (x max travel, mm)
$131=790.000 (y max travel, mm)
$132=100.000 (z max travel, mm)


Take a look at the settings in the link above. In your settings 130 and 131 are correct for the 1000mm unit.

Thanks Larry. The settings in that link were the settings I used originally that gave me odd results. They cause the steppers to move way too fast, thus over driving them and causing them to stall. The stock settings with only $110 and $111 changed drive the steppers insanely slow. I cannot seem to find a happy medium.

That’s really odd. I’ve been reading this forum for a long time and this is the first time I have read that the motors are moving too fast. Most of the machines that I have answered grbl questions on have the default parameters, or have 110 and 111 at 5000.000.

You might try that to see how it works for you.

Also, I remember this from the X-carve web site:

The larger 262oz-in NEMA 23 stepper motors are not recommended to be used with the X-Carve due to the capabilities of the stock electronics and may not fit the Z-Axis.

Which is confusing, because the current limit, according to the web site, is the same for both the 262 and 140 oz-in motors.

Since you are using the 270oz nema 23s, I’d suggest just cranking the pots up to their max and see if that solves anything. Else you should try Larry’s suggestion. Also check your jumper pins on the gshield, and make sure that the Z-axis is set to 2x microstepping and that X and Y are set to 8x.

My 1000x1000 has Nema 23’s and there’s no problems with that unit at all (once I’d got the pots adjusted correctly). I’m using everything that came with the standard machine except for the DeWalt that hangs off the front.

I believe that the standard machine comes with the 140 oz-in NEMA 23s.

D’oh! Sorry,

Alright. I seem to have worked out the speed issue. That was indeed the $10 and $11 settings. Thanks for that Larry. As for the steppers they were getting too much current which I was not expecting. I have adjusted the pots and everything has been running pretty smooth so far. Thanks for the help guys!

Changing 110 and 111 to 8000 fixed my problem as well after fixing a corrupt grbl.