(Resolved) Y-axis motors moving in opposite directions

Like topic says, I finally got everything finished and ready to go and when I was checking my motors before I ran the first project my y-axis motors are going in opposite directions. Everything seems to be wired correctly. So I’m not sure what could be going on. And I’m not sure which wires to try swapping since there are 4 coming from the motors.


When you go to Easel, run Machine setup. You’ll see arrow keys on screen click and see if directions correct, if not you can click no instead, it will chance polarity automatically. When it is moving correct direction you have to click Yes then move on for the next. It is one time deal.

Machine setup is where I figured out I had a problem. It’s not that they are moving in the wrong direction. The two motors are moving in opposite directions, as in one moves forward and one moves backwards when they should both be moving forward.

Nevermind. I figured it out. I had all the wire colors matched up for my y-axis when I need to have the white and red on one side reversed.


That part is in the instructions but I missed it too :smile:

sorry mate what did you do to fix the problem

Which wires did you change, I’m having the same issue.
Thank You

Thanks for the response. I did get this fixed last night. Now the issue is the y and z axis are not going the right direction. During the setup it asks if I want to reverse this and I clicked yes but it didn’t make any difference.

Have you tried to restart the system to see if the change came into effect?
Optionally yoy can swap around any one pair of the 4 wires coming out of each stepper motor to change its direction :slight_smile:

1 Like

Thanks so much for the detailed responses!
I’ll look into the code, but I’m starting from square one with that so there’s going to be some learning curve. Could this be dealt with by changing wiring somewhere?

I’m going to work on the wiring side with customer support. How do I even access this code?

It said I needed some kind of terminal program to access it

There’s been other reports of the Xcarve setup screen in Easel not being able to reverse polarity for multiple axis. It’s most likely an Easel bug so reporting it would help let Inventables be aware of it.

As for changing $3, what Phil is referring to is inside of Easel when you go to Machine -> Advanced -> Machine Inspector, one of the fields is called command prompt. This field is where you enter in the “$3” line.

1 Like

Cool, thanks!

I just resolved the same issue on my home built CNC. I swapped A+ and A-, which changed the direction of the stepper.