[Resolved] Yet another X axis problem (Linuxcnc)

I’ve made a few test cuts with little success. First test was to cut a couple of profiles to check measurements, theses came out OK. I then tried a couple of pockets and this is when the problem showed up. It seems that the X axis is slipping.
Here’s the profile cuts. 3mm bit, 800mm/m feedrate, .4mm DOC.

Here’s the pocket cut, same parameters used to cut it.

Y dimension does not seem to change, just the X axis
Wheels are adjusted to be tight but I can still turn them manually, belt tension is adjusted as per the various threads using a fish scale. I’m running a Gecko G540 controller under Linuxcnc, not the arduino based controller.
When assembling, I did manage to miss-cut the belt and ended up short so used some belt I had on hand. The only difference I know of is that belt is that it is reinforced with kevlar rather than fibreglass. I’m sure this will make no difference but thought it worth a mention. I’ve ordered some more GT2 belt just in case.

Check your pullies, the ones attached to your steppers with 2 little hex set screws, i had mine become loose after a few cuts the first time and didn’t even notice it.

Pulleys were the first thing I checked, nice and tight.
I’ve ordered some new belt just in case the stuff I used has a problem.

EDIT: Another thing I double checked was that the belt was GT2 and not MXL. I had some MXL left over from an Ord Hadron build. That would have been embarrassing :grinning:

I found some GT2 belt (fibreglass) so I replaced the X axis belt. No change to the problem. I’ve changed the controller connection so the X axis is running on the port that was driving the Y axis, software reconfigured to suit, Still get the problem.

As I’ve mentioned, I’m running a Gecko G540 under Linuxcnc, is anyone else running this combination with an X-Carve? I’ve all but eliminated any mechanical issues so controller/software is next on the list. I’m confident that the controller is OK as I’ve used it to drive a 6040 CNC router with no problem. If anyone want to share a Linuxcnc configuration for the Gecko/X-Carve I’d appreciate it.

Turns out that even though my PC passed the Linuxcnc tests and reported being able to run things at a certain speed, it lied!
The Gecko controllers can work with a 1μsec stepping pulse, the PC can’t reliably generate them at that rate but no error messages are generated.
I changed the pulse width to 2μsec and all was well. This will restrict the maximum stepping rate possible but I’m pretty sure that that will still be faster than I’d like to run the X-Carve.
Image shows the same letters cut 3 times over the top of each other (3 separate runs of the g-code), repeatability is very good!
Now to level the bed.

1 Like