Restarting jobs (perhaps mostly a UGS issue)

I’m working my way through a problem I’m experiencing where a job will just randomly stop part way through. Everything appears to keep running, however everything also appears to be completely locked up.

I’m creating code in VCarve pro and using UGS to send it from my Mac to the cnc. The failure is not code or job specific, nor is it machine specific - I’ve connected a Win 10 machine (Suface Pro 4) running the latest stable version of UGS and the latest java updates and the fault still (randomly) occurs.

I suspect a cabling, connection type of problem which as mentioned, I’m working through. My question however, is this:

Once my system has stopped responding, is there any GCode manner of restarting it?

When these failures occur, I’ve tried several things, “Soft resets”, “$X”, “Return to zero” etc. I’ve tried unplugging the USB, restating GRBL (turning the XC off and then on), killing UGS etc, however the only successful method I have, is to shut everything down and then rebooting the computer, restarting GRBL, reconnecting, re-homing, returning to zero and then beginning again.

I don’t doubt I’ll eventually find the fault, but is there a faster method of restarting these failed job? Not a major issue I know, but it is frustrating and very time consuming.

Any suggestions would be appreciated.

Two possibilities I can think of.

  1. You’re receiving false Limit switch trigger if you used soft limits.
  2. You UGS have small amount of buffer configuration. Check following picture how to increase it. Just change it to 4096.

Most likely your failed restart is due to the serial port being tied up by UGCS that doesn’t terminate normally. To clear the port you can go to Device Manager and disable the COM port that your system uses for the Xcarve, then enable the port. That should free the port.

Once that’s done, try one of your methods to reset the Arduino/Xcontroller till you find one that works.

1 Like

Which one was triggering, hard limits?

I never use switches, so there was a Big discussion bout false triggering, maybe after changing switches as limit switch. You also made big noise, crying out laud about static interferance on switches. Am I wrong?

Thanks @LarryM and @AlanDavis (and others). I have a couple of questions…

Is changing the buffer size something I can do on a Mac? I generally use a Mac for running my machine which is why I wad surprised that the same fault still occurred when running on a new PC.

Can I disable and reenable the com port on the Mac? I think I know how on the PC, but as far as the Mac, I’m just a dumb user.

Sorry, I can’t help with the MAC. I don’t use them.

I’m not familiar with mac system. All I can say is that start-up batch file for java start. If mac is using java differently it doesn’t work. Just try to see, or give it a little time 'til some one joins and gives better idea.

1 Like