Return home interrupted by motor start

I have a Variable Frequency Drive and a brushless motor on my X-Carve.
All seemed fine until recently when jobs began to halt part way through. I’ve also noticed that when the X-Carve is set to go home and while it’s travelling I turn on the motor, the x-carve stops moving.
The VFD or motor seems to be affecting the signal to the Arduino perhaps?

I was having the same issue the other day. Had the VFD sitting next to the computer for convienance. When I would power it up the com would lose connection with the XController. Moved it to the other side of the machine and all was well. Can I ask what VFD your using?

Switching transistors in your vfd, are affecting your arduino. Try moving it away, shielding, and grounding.

The vfd is an AskPower A131 series

Seems to be getting more bizarre.
If I have the motor running and click on Home in grblControl, the status shows Alarm and the X-Carve just moves slightly and then does nothing. If I then turn the VFD off and do the same it goes back to the home position quite happily.
It didn’t used to behave like this and has been fine for the best part of a year.
Perhaps the VFD has gone on the blink?

Hmm. Have you had everything grounded with shielded cable from the start or is it unshielded? Trying to get a gauge of your setup. Also do you have automatic spindel control through the controller?

Done some more elimination and I think I know where things are going wrong.

  • I disconnected the motor from the VFD and then did the home test and powered on the VFD and all was OK.
  • I reconnected the motor to the VFD, powered it on and retested with the Home test and that failed.
  • The power cable to the motor runs in the drag chain so I removed it and retested with the Home test with the FVD powered on and it worked OK.
  • If I move the cable closer to the X-Carve with the VFD powered on the Home test fails.

It would appear that the power to the motor is interfering with the X-Carve control signals.

Check for loose wiring to the motor. If you have plugs/sockets in the motor wiring path check them for corroded contacts or loose contacts.

Just had a good poke around and there are no loose wires. It seems to be the proximity of the motor power cable to the x-carve or arduino that causes the trouble.

Didn’t your system work for a while before you started experiencing the problem? If so, I’m curious to know what changed and caused the new problem.

It sounds like something in the system has weakened over time and what used to work fine, doesn’t work now. Is this correct?

Make sure your limit switch wiring is twisted and shielded. You might want to add some capacitors to your limit switch comments. That is what I had to do. Even though I didn’t have a VFD I was having issues.

No problems now…

I installed the VFD and new spindle in Feb 16 and have used it a lot since then without a problem. The start of it all was when I was cutting some aluminium (I have an extractor so control the bits of flying metal) and the VFD failed with an overcurrent error. I turned off, restarted and it did again a couple of times more and then was OK from then on.
The Ground wire on the limit switches came loose and was dangling for a while and I couldn’t understand why the X-Carve wouldn’t go home. I eventually spotted the loose wire and reconnected the ground and the Home then worked ok.
I think it was after all this that the VFD started to interfere with the X-Carve. When I turn on the VFD when the spindle is connected and the X-Carve is running it causes the X-Carve to go into error (as reported by grblControl)

If you are comfortable with soldering, I would put 0.47uf 50 volt ceramic capacitors on your homing switch lines. The ceramics are not polarized so you can hook up either lead to the signal wire and the other lead to ground. One for each axis. Place them as close to the gShield as is practical.

If you have the X-controller you can just hooked them into the screw terminals.

That will serve as a low pass filter and will improve the noise immunity of your system.

Moving the VFD wire around may eliminate the problem, but if something were to bump it, it might cause a failed carve.

Completely packed up now :cry:
I was running a facing job on my x-carve baseboard and, like it’s done on a few occasions recently, it came to a halt part way through. Before I started the job I’d moved the motor power cable away (I replaced it and re-soldered the connections earlier for good measure) and I thought I’d see if it had helped cure the problem. It turns out the answer is no. It now won’t respond to any grblControl commands at all. grblControl knows it’s there because when I plug the USB cable in it sets it in Alarm mode. I can clear the alarm but that’s about it - no response to any command whatsoever. I’ve done all the usual stuff; powered off/on, rebooted the PC, uninstalled Arduino drivers and re-installed, disconnected the power to the spindle but nothing, not a peep. grblControl thinks it’s sending commands to the X-carve because the coordinates change when I hit the jog buttons but nothing comes out the other end.

Just connected to COM3 through the Arduino IDE Serial Monitor. It connects to COM3 OK but any commands I send are ignored.

In the serial monitor do you have the baud rate set to 115200 and the “end of line” set to “newline”?

yes, 115200 and EOL=Newline.
When I start the serial monitor the x-carve makes a small noise to acknowledge that something has connected to it.
I reckon the controller is knackered, which may explain the odd behaviour with the VFD. Hopefully it’s not knackered but I’m anticipating the worst. It’s only 13 months old. Funny how stuff only goes wrong just outside warranty.

I would try disconnecting everything from the Arduino except the USB cable and then see if you can access grbl.

It that works ok, then it’s not the Arduino. If that doesn’t work then you may need a new one. At least they are not terribly expensive.

You could try re-loading grbl into the Arduino.

Dismantled and reloaded grbl and ran through the Easel setup and all working again now :smile:
I’ve still got the problem where the power to the spindle causes the home sequence to be interrupted. I’ll get some of those ceramic capacitors and give them a try. One leg of each capacitor to the white wire from each switch and the other leg to ground?

1 Like

Yes. There is a ground connection to the gShield in the wiring connector for the homing switches. Use that ground.

Is the cable to the motor shielded and grounded?