Inventables Community Forum

Setup issue

HI all, first post. Got my 1000 x 1000 X-carve assembled and running yesterday with a minimum of problems. Thanks in large part to this forum. It took awhile to get the Gshield loaded correctly and the happy green lights. When I finally got the green lights, Easel would still not recognize x-carve. After searching this forum for the 100th time I loaded a slightly older version of Easel locale and boom, everything worked. Ran through the test carve and a bunch of other projects ( just “air carving” ) to test and play with machine…all with Easel. Everything worked great.
Now here comes the problem. Today I went out with the intention of testing it with UGS. Like an idiot I opened the Adruino software instead of UGS. I tried to open a .nc program that I created in Fusion 360. Nothing happened. So then I hit the upload button in the Adruino interface and although I didn’t have anything selected it did something( down in the comment section). Keep in mind that I was still brain dead and thought I was in UGS. Also at this point I did not have power supply cut on but usb cable was connected.
Since I couldn’t get my file to load I decided to just play with the machine through Easel. I cut on the power supply and guess what? no green lights. I made sure gshield was still connected properly, checked ports (computer still saw Adruino on com 4, deleted and re-installed the Adruino IDE and drivers and everything else I could think of. No green lights on the gshield and Easel just stops when I enter com port.
could I have wiped the Adruino? or could there be another problem? Sorry for the long post but wanted to try to explain all that happened.
Any help is appreciated. Thanks, Stan

It sounds like you have wiped out grbl. You will have to reflash the Arduino with grbl.

Or you can use this:

Yeah, I was afraid of that. I am fairly new to this but I will give it a try as soon as I can. Looks like doing it through the Adruino IDE would be the easiest way to go. Thanks!

Quick question. If I follow these instructions “You can also upload the Hex file to the Arduino in the Arudino IDE by following these instructions.” in one of the links above, is that all I have to do? It mentions downloading the fork file but nothing about a hex file.

The fork file is the hex file. The term fork is used in software engineering. A project fork happens when developers take a copy of source code and start independent development on it, creating a distinct and separate file. Think of it like a fork in the road.

The hex file for X-Carve is a “fork” of the generic GRBL hex file.


It would be a good idea to repeat the Machine Setup instructions in Easel once you have grbl back in the Arduino.

And I thought i was pretty computer literate :grin:. I’ll give it a try hopefully tomorrow evening. Thanks again for your help. I would like to say the whole assembly project was great. Great packaging, great instructions, and helpful forum!

Got the Arduino re-flashed and ran through the Easel setup. Everything is good. Thank you much for your help!!

1 Like