Shapeoko pro not connecting with Easel?

I’m very new to CNC. I just started learning about 2 weeks ago, and I’m slowly catching on to things. I’ve done a few signs and candy trays, but I’m eager to do some 3d stuff. My problem is I can’t seem to get Easel pro to connect/recognize my machine ( Shapeoko pro-XXL) I was under the impression that I could plug into my laptop set up a few things and go. I guess I can’t be so lucky.


I’m not sure if this image will show but I uploaded it to show where I’m stuck on.
When I plug in the laptop to my CNC I go through some setup and also it does not list my model in the machines list so I check off other? I get to this page and it just sits there. It says “(connecting to other GRBL) turn on your machine & plug-in USB cable” and that’s as far as I get.
I’ve seen many videos of people using my machine with easel and they say it’s very simple to use but there is nothing i can find for software set up. I want to use easel because it seems to have great ratings and is supposed to be very user-friendly lol. Thank you.

I wouldn’t use easel to control your Shapeoko. Just download the gcode and use Motion or something like gSender.

1 Like

you may be missing drivers, To load the missing drivers the easist way is to plug in the USB cable to both the CNC and computer and with the CNC powered on, (and the Estop button up fully) restart windows and as windows boots up it will auto install the missing driver for the CNC.

HOWEVER I agree with Neil and Carbide Motion is the Best gcode sender for a Shapeoko.
gSender isn’t a bad 2nd option either, but is more involved techwise to setup than Carbide Motion.

Thanks alot for the help. Im going to go with what u suggest and use the G-code. After looking further into this I also noticed many others use this method.

1 Like