Simulater locked up

simulater screen is full page can’t return to edit side

Try a different browser. Chrome seems to work best. I’ve never seen anybody use Brave browser before.

There are internal popups on that left screen, Brave might sense this and have disabled the entire pane :man_shrugging:

I tried firefox and chrome. Same reaction. I think I expanded to far to the left and there is no return option.

Is this bar (yellow highlight on the left) visible on any of the browsers?
I don’t see it in the screenshot so you can just skip brave and check the other ones…
3 dots to drag, Arrows to make the design pane full screen…


There are no dots to drag. Tried chrome and firefox.

It seems to be working for me, here’s what I used, same as what Seth suggested:

1 Like

There are no dots on either browser.

What device is this? and its operating system.

Have you tried exiting, restarting the device and going back into the project and still no design pane?

I think the problem is Easel does not like opening another gcode that has been generated by another source or person.

It is a windows 10 Dell PC

Only happens when a gcode is imported.

You cannot Edit a gcode file in the traditional sense. This completely explains what your experiencing.

Yes, the design pane goes away when gcode is imported, this is because it is not a project file and thus cannot be modified within Easel. there are programs to reverse engineer a gcode file to kindof create a 3d model of the design which you would then need a 3d model editing program like Fusion360 or Solidworks, or maybe Blender to modify, but simply modifying the file in Easel is not possible.

When importing a gcode file into Easel you are using Easel as a GCode Sender only, so the options that are present in the design pane are removed.

1 Like

Just one note on importing Gcode into Easel…
Make sure you are creating the CORRECT Gcode for Easel. every controller board needs to have the Gcode tailor made for that specific controller by using the correct post processor.
For Easel i have used the Xcarve post processor to create Gcode in Aspire, and it works great.

When ever you create a Gcode program. It has to be created for that specific controller.
there are about 100 Gcodes in a Gcode library, and Easel will only accecpt about 10 of them, and out of those ten, only 7 or 8 are used…
So, to create a Gcode program for Easel, for example in Aspire, i need to use the Xcarve post processor to create the correct Gcode for the contoller used…
In most big CNC machines G2 and G3 are used to create circles… Easel will crash there if it sees a G2 or G3… Easel creates circles by using tiny tiny straight line to build up a circle…
just an example.

I appreciate the help from both you guys. That is some what I had in mind. Thanks for all the support.