Simulating detail toolpaths

I have been trying for the past two days to do a project but when I hit carve or simulate it gets stuck saying “simulating detail toolpaths”. Tried logging out, and back in. Tried clearing browser cache, reboot computer and I can’t get past this. This is happening with all my projects. I have read other similar threads and have followed all the suggestions and still nothing gets me out of this loop.
Please HELP!

Done first 3d carve, works OK
Often when checking ‘show preview’ after some minor adjustment gets stuck ‘generating preview’.
Is this done on the PC or via internet connection ?

This is done via internet connection.

OK, slow connection then.

No. Excellent connection.

To clarify, Easels toolpath calculation has nothing to do with internet speed or quality of connection.

If you can share the project and post the share link here, we can take a look at your specific project to possibly identify the cause of the issue.
The share process is shown in the 2nd half of this: