Single line fonts

Any chance on single line fonts being added? Plain text, italic, a fancy handwriting style font?

Something single line that can be used with the finer bits and just carve single line versus outline, fill or cut inside line.

Looking to do a lot of text but single line with the 1/32 or 1/16 bits

1 Like

I’m sure others can provide more detail, but my understanding is you can import your text from many other applications.

Whilst I use VCarve mostly, the text options are relatively meagre.

I use another application to design the text and layout and then import that work into VCarve. I quite sure Easel can do the same.

I’ve tried importing thin line fonts. But easel wants only to cut the outline,in line or fill options not just trace the single line.

Or the bits are to large for some of those cut lines. I would just like to use a small bit and have it cut a single line for text. So I can achieve small text

It might not be ideal, but if you have CorelDraw you can use the technique below. It works pretty well.

The latest version of Inkskape has Hershey text (single stroke fonts) built-in.

I’m guessing a Plug-In programmer around here could make use of this:

Are you referring to the single-line fonts in VCarve? I’d like to see more there also! Fortunately, there’s no limit to TT fonts in VCarve.

If you get really stuck you could import Hershey fonts into Easel as SVGs and typeset it yourself.



Add my name to the list of those who would like to see single-line fonts added to Easel. I’d like to be able to engrave signs with scientific names so I also need a single-line font in italics.

1 Like

Ditto - Single-line fonts are on my wish list as well.

1 Like

I’m all for single line fonts being natively supported on easel… and here’s why.
I have been tasked with making office door signage. The originals looked like this:

Simple right? nope…
Here’s what happens when I import the text (cambam font) converted to paths from Inkscape

  1. The spacing for the objects gets thrown off every time. This is most noticeable with the “i” shaped objects.
  2. The toolpath is all jacked up. Why can’t it just follow a path? I have tried On Path, Inside, outside, and even Fill. The lines are THERE, why can’t I just follow those lines?

Admittedly, I’m using a 1/16" ball end mill, but seeing as I only need to cut a mere .003" to remove the black top layer, the cutting diameter should be negligible.

Am overlooking something? Or am I just going to have to give in and “invest” in VCarve Pro? Maybe some 2.5D freeware??? Such a simple operation should be able to accomplish with easle.

Please let me know if I’m just being newb and call me out. I will am very open to criticism at this point.


Alex - I’ve read elsewhere of similar problems with cambam fonts:

I do want to ask - where did you get your cambam font for inkscape?

I’m using Hershey fonts but running into some problems.

  1. I’ve installed EvilMadScientist Hershey font extension pack:
  2. I create a simple “Hello World” sample.
  3. Select the text sample and Ctrl+Shift+C (converted to paths in Inkscape)
  4. Save as .svg
  5. In Easel, import and I get “Failed Importing” msg

What am I missing? Thank you.

I tried and failed, then I saved as DXF and reloaded into Inkscape saved as SVG and was able to load it into Easel

Glenn - that worked for me as well. I find you need to ‘Simplify’ a few times to get the lines to look right in Easel. But overall it works. Thanks for that tip!

When I do this I just get a black blob in easel no text

Any ideas ?


Yes, I’ve seen that before. It appears to look like a text block. Simply select the black blob and click delete. It should go away and than you should be able to see your text.

it deletes the whole thing no text left over

1 Like

I just did a google search for stick fonts and stumbled upon CamBam

To fix your import error, try saving the SVG file as “Plain SVG” not “Inkscape SVG”… see if that works. You’ve got the right idea. Unfortunately, you will come to the same dead end that I did. Check out my other post on Reddit that has gotten a few constructive solutions. None of which involve Easel unfortunately. The support for single line font engraving is just not as easy as I thought it should be

Were you able to get a tool path for the imported single line font?

GrantFlude - try selecting just the corner of the black box. Perhaps the box and text are getting selected. Otherwise, I’m not sure what to say as it always worked for me.

AlejandroMMarez - Yes, Easel generates tool paths for the imported single line font.