Skipping on Rounded Cuts

Issue: Xcarve is unable to make repeat passes when completing rounded cuts. Cut veers off-line, appearing to skip in the x-axis.

Context: Attempting to complete a large cut (28"x20"), approximately 45 minutes in duration. The shape is essentially a rounded rectangle. All corers cut smoothly except or the far right corner which was cut last.

Trouble Shooting Attempted:

  1. Brush clean all rails, belts, etc. Same result
  2. Restart Easel and Arduino. Same result
  3. Updated Easel design file to only include the rounded cut at issue and move to origin. center bit over intended cut location on part (testing the ability to complete a simple rounded shape). Same result
    Thoughts: all linear cuts in the X and Y direction were completed without issue. I’m unsure why only the rounded cuts would be skipping in the X direction. Because of this, I’m tempted to blame software. Please help!

I can only suggest that the cutter forces are greater in corners AND/OR depth due to chatter AND/OR non-prependicular Z axis (out of tram). Did you hear a “grinding noise” when the bit started to drift off course?

What depth per pass are you trying to cut with?
For a 1/8" bit (a guess) it looks like you may be trying to cut too deep on a single pass. When cutting with the grain, cutting forces are less than cutting cross grain.

Hmmm, interesting point about cutting forces when cutting against the grain. Here are some more details about the settings I was using:

  • Cutting Bit: 1/8" Solid Carbide 2 Flute Spiral Upcut (Ball Nose End)
  • Depth per cut: 0.05"
  • Feed Rate: 40"/min
  • Plunge Rate: 12"/min
  • Spindle Speed: 1
  • Material: Birch plywood
  • Sound: There was, of course, a different noise when the bit drifted off course because it was suddenly cutting at much deeper depth. There was distinct noise prior to the cut drifting off course

Follow up questions:

  • If the cause was cutting forces aghast the grain, how come the cut appears to be skipping in the X direction (with the grain)? Also, should I see skipping on other linear cuts against the grain if this was the cause?
  • Does anything stick out about the cutting setting listed above that may be causing the issue?

Nothing wrong with your cut setting to me. Your picture really looks to me like the actual cut depth is way more than 0.05" per pass. The cut goes through several layers of ply.

Please post the first 10 lines of your gcode file.

1 Like

Hey so here’s the first 10 lines of G-Code…

G1 Z0.15000 F9.0
G0 X1.71783 Y21.00000
G1 Z-0.05000 F12.0
G1 X26.31833 Y21.00000 F40.0
G1 Z0.15000 F12.0
G0 X1.71783 Y21.00000
G1 Z-0.10000 F12.0
G1 X26.31833 Y21.00000 F40.0

I also looked in the $102 z-axis mm/step and it’s set to the default of 188.947

Note: That image is after a couple of successful passes. To clarify it makes a couple clean passes first and then makes the error…

OK, thanks. This code snippet cuts a straight line in two passes. First pass is at -.05 depth, and then bit drops to -.1 and makes the second pass. There is no curve to this, so I would like to look at the rest of the code to be sure the curves are being cut the same. We can either verify or eliminate the gcode file if the curves cut the same.

Please zip the file and send to me as an attachment, if you wish, at:
picengrave AT
I will run the complete file as a simulation to check the curves.

1 Like