Soft Limits / Reset

Can some please advise how to perform a “soft reset” after a soft limit violation. After searching the forum on this topic, I found the following:
Ctrl-X - didn’t seem to do anything!!!
$X - didn’t seem to do anything!!!
Open and Close the COM port - I have no idea how to do that.
It seems one is advised to re-home the machine after a soft reset, but I haven’t been able to get that far. The “Home Machine” option is no longer a choice and $H is not responsive.

You should be able to send the following commands in this order:

  1. ctrl-x
  2. $H

The “ctrl-x” should trigger GRBL to perform a “Soft Reset” …
The “$H” will home the machine …

Both are required to reset from a Soft Limit trigger.


Brandon Parker

Thanks!!! But I tried both of those and the machine would not respond.

If you’re homing the machine anyway, just power off and back on.

What program are you using to control it?

That definitely works!!! I just figured that with all the references to soft reset, Ctrl-X, $X, etc there had to be a more sophisticated process than simply turning the machine off, then re-starting it.
I’m using Easel and always home the machine before I start any job.

I did find a reference to the Reset button on the X-Controller, but my read of it was that it only worked when the machine was running a job. My problem occurred when I was jogging the machine after completing the Z-Axis upgrade and trying to find the best position for it…not too high/not too low.

Thanks for your help!!!

You can’t type Ctrl+x and have it automatically sent to the controller. This is the job of the user interface to send 0x18 (Ctrl+x). I don’t use Easel, so I can’t help with that.

As I mentioned, the command is 0x18 for a reset. It’s in the code, obviously. I can point you to specific locations when I get to a PC. All of these commands are user configurable, compile time. I think it’s just in the config file of you wanted to change it (I wouldn’t recommend that).

The code snippet you quoted above is for the $X unlock command… Not the same as a soft reset.

What is?

Yeah, I see…

ctrl-x is defined in config.h on line #48.

#define CMD_RESET 0x18 // ctrl-x.

And, the mc_reset() method is called on line #151 of serial.c.

case CMD_RESET:         mc_reset(); break; // Call motion control reset routine.

For some reason, I was fixated on trying to find it in the system_execute_line() method of system.c, maybe because I was thinking that recovering from a Soft Limit Alarm would be in the serial input ISR()… I have removed my errant posts to prevent any confusion…

So, if Easel isn’t interpreting & sending the “ctrl-x” as 0x18 when typed into the Machine Inspector’s Console TextBox then this is something that needs to be reported as a bug to Inventables.


Brandon Parker

I don’t know if it’s a bug, but it sounds like it’s a missing feature. Most Grbl GUIs have a “Reset” button. I take it Easel doesn’t have one?
You can’t send ctrl+x through the serial console because it only takes ASCII characters.

I’d suggest not doing that. The conversation becomes more confusing. It’s ok to post imperfect replies. The forum it’s not a technical document.

For the most part, I agree, but in this case, I disagree. My reply was in left field, and I should not have posted it. I should have studied the code longer, but alas…my two-year-old…


Brandon Parker

C’mon… You’re not in it until you have three under 6yo!
Our oldest is now in first grade. Youngest is 19mo.

For what it’s worth, I got a call-back from Inventables Support on this issue, and they had no answer other than what Neil suggested…turn the machine off and then re-start.

As well, they advised “turning-off” Soft Limits!!!

So now I’m a little confused. The Z-Axis upgrade instructions clearly state to revise the $132 setting to reflect the new travel distance of this upgrade. But, as I understand it, this setting (along with $130 & $131) only function when Soft Limits are turned on.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.