Inventables Community Forum

SOLIDWORKS to Easel - Macro to Convert Faces to SVG

i do know what is going one I will try it again and see
thanks

Just downloaded and installed your macro into Solidworks 2019 using your YouTube tutorial and it works. Thank you!!
Working with simple shapes in thin aluminum sheet and this makes it a very simple process.

Glad to hear it’s working for you. Let me know if you run into any problems.

Hi Ethan,
Great tool you have created - However I have some problems getting the Macro to work.

My history is like this:
I use SW2018 and firstly installed the 1.03 version - However I got the run-time error (as you made a fix for).
I tried the newest 1.05 version - However experienced the same issue as AhmedElbassal, that the “toolbox” doesn’t open when I click the icon.
So 1.04 must was my next try - However when I import the SVG file into Easel (based on your SW part) I get an error “We can’t import this SVG”.

I asked a colleague who has SW2019 and the 1.05 version works for him, however he also gets the “We can’t import this SVG” when trying to upload to Easel.

Would you mind checking that the tool still works for you (and the it is not a change in Easel I’m struggling with)?
I hope you have a little time to support in this matter because it would be an excellent too for me to use :slight_smile:

Thanks

Hi Anders,

Would you mind sharing the svg file with me? I might be able to figure out what line in the svg is causing the hangup with Easel and backtrack from there.

I’m still on SW2018 and haven’t seen the issue with importing into Easel yet, but I’m willing to take a look. Does your SW model have any unusual geometry to it?

Cheers,
Ethan

Hi Ethan,

Thanks for your swift reply! :smile:
Sorry, I miswrote - I’m on SW2017 and colleague is on SW2019.

I have uploaded my own part file here:
https://drive.google.com/open?id=1exgltQ8f1awiU_vd0BzPdihxTJEvv4Gv

I also uploaded the my SW2017 SVG files of my own part, as well as your “test” part - Done with v1.4.
Included is also my colleagues SW2019 SVG files of my own part, as well as your “test” part - Done with v1.5.

The geometry of my model is very basic, however the part will have to fit with quite tight tolerances with other parts, which is why the Face2SVG macro would make life very easy for me.

Thanks so much for you help I really appreciate it.

Br.
Anders

I just figured out the issue…

You use “,” as the decimal separator don’t you? :slight_smile:

Currently the program only supports the “.” decimal separator. I’ll have to see if i can force SW to use the “.” separator when exporting the svg.

Will let you know soon.

Cheers,
Ethan

Face2SVG_V1.06.zip (4.3 MB)

Hi Anders,

Above is an update that should take care of the decimal issue. Please let me know if this works for you.

Cheers,
Ethan

Hi Ethan,

Yes, I use “,” so could likely be the cause.
I will check it as soon as I get to my workstation and let you know.
Thanks in advance and really awesome you take the time to help.

Br. Anders

Hi Ethan,

Just tried it with a few different files and all seems to work perfectly on my SW2017 version!
I can’t thanks you enough, this is an awesome macro.

Let me know, if I can in any way return the favour.
Once again thanks for the support - You are a legend :smiley:

Br. Anders

Glad to hear it’s working!

I love when it’s an easy thing to fix.

Cheers,
Ethan

Hello sir, I did the same way as you did on the icon, but there was no response. What is the problem?

Hey Ethan excited to use this macro. When click to choose a filepath to save it gives me thi error. Any ideas?

Thanks

Hi @SpencerStewart, are you using the latest version of the macro? 1.06