[Solved]Complete reset? I'm out of ideas.......X-controller gone bad?

I will try o keep this short and to the point.It started with homing and the switches associated with it. I recently enabled homing so I could use the same location (G28) with a bump stop. I firmly believe that Easel hates my guts and have never been able to use Homing within Easel with out smashing Z switches, yes plural, as in many switches smashed.
I have PicSender installed for my laser and got some help from @LarryM on how to set up homing with PS and it worked great, thanks Larry! So anything I made in Easel I would generate Gcode and run it in PicSender, no problem, until yesterday, I would start a carve and it would stop 10% into the carve.
So I thought it was an issue with PicSender and got some very prompt attention from the guys at Picengrave.
I’ve tried everything short of uninstalling everything and doing a fresh install. So I think its got something to do with my X-controller.

I have the latest firmware installed, I tried the latest Easel driver 3.2 no difference, so I went back to the current driver 2.7.

I tried starting from the beginning. I tried to disable homing I still get “home” buttons when I hit the carve button. So I hit the unlock button and I try to jog the machine in Easel, It will let me lower the spindle, but when I use the other jog keys it freezes up. Yes I have changed out the USB cables.
I’ve been all over the forum and finally broke down and reached to all of you folks. Has anybody had any problems like this?

I haven’t boogered up any carves yet but I have paying customers expecting product at the absolute worst time of the year for my XC to break down…help

Is your usb cable running direct from the computer or through a usb hub? Is it a powered or unpowered usb hub (if youre using a hub)?

The cable is direct from the Xcontroller to the CPU

If you think it’s the X-Controller, reflash it, and make sure you power cycle the X-Controller. Then reboot your computer.

edit: And if you have a powered hub, try it.

I know I can find instructions on the reflash, but I’m not sure how to power cycle the X-controller.

Turn it off, uplug it, let it sit for a few seconds, plug it back in, and turn it on!

Yes Steve, everything has been shut down, unplugged and rebooted.

Like Steve said, use a powered hub.

@SteveWalker, no worries, I appreciate your help. BTW, right after I laughed my ■■■ off reading your butt hole comment, I thought, what the hell, so I pulled up Easel like I would normally, and went through the standard motions without “Homing” (I disabled Homing earlier, apparently it took a while for Easel to catch up) and it worked without a hitch! I don’t know whats going on with the Homing and Easel, but for now, I am not going to use Homing so I can get some work done.
Thanks everybody!

1 Like

Good to hear. I just sent you a PM.

1 Like

The Z axis has a threaded hole so you can put a bump stop there to prevent the switch from getting damaged.

See it here next to the bolt holding that bearing in. (on the bottom side of the image.)

Get a bolt long enough to use as a stop and you can get a small rubber tip to go on the end. This will hit the Z and prevent it from traveling too far and smashing the Z Switch.

I did a whole explanation before in another thread.
If you do not have a hole there then make one and tap it. Make sure it lines up with the edge of the Z axis that moves (Top edge in the pic of the mount)

1 Like

Thanks Steve, I got the idea to use a solid block of aluminum from your thread and @LarryM’s guidance. While it obviously keeps the switch from getting smashed, when I was using homing with Easel I would get homing errors saying there was an obstruction. No kiddin, really? So I have a little more digging to do to figure that out… It’s funny, when homing was enabled in Easel, I couldn’t use it, but homing worked in PicSender just fine.

That is strange.
I have never had any issues cept with the Z axis making strange grinding noises.

So, I have since reset grbl, did the ease machine setup, spent some quality time/ emails with the amazing guys from picengrave @JohnChamplain @picengravertoo and finally got my machine back on track. Homing is working as it should in Easel and picsender, and @John Champlain dug into a gcode file of mine and noticed that there some errors and showed me how to fix those, I guess this post can be “Solved”. Thanks everybody!


Bill, glad all is OK now. Thanks for the feedback and good words. Much appreciated.
All the best,

1 Like

A simple thanks is not nearly enough John, I didn’t mention that you did all of this for me on thanksgiving when you should have been watching football, eating turkey, and hanging out with family. I’m so humbled by your generosity with your time.
Whatever I can do for you, please just ask.


Just pass it on when you can. I certainly had lots of help over the years, too.