[Solved] Cutting wrong, loosing position

I’ve been playing with this for a bit now, but i’m stumped, i’m very new to all of this.
i start a job and after a little white into the job easel seems to loose its position and starts cutting its 2nd or 3rd pass in a new location. could this be caused by a bad internet connection? or do i have something else going on?

thanks for any advice you can give this helpless noob

Check and see if your belts are slipping

I havent gottenmy machine yet, but I have been checking the forum regularly and have come across a couple of possibilities.
Belt tension and feed rate.

Belt tension is supposed to be guitar string tight Kind of subjective but without the proper gauges…

Feed rate would be both while cutting and when in rapid transit. Coupled with belt tension, you may be jumping teeth on your belts if it’s zipping along too quick.

Thanks for the replies :blush
I thought of that also and tightened the belts and lowered the feed rate to ten and it still did it, it seems to do it with a large job. I ran something small and it worked fine.
I have the worst internet in America so I was thinking maybe I was losing connection with easel during the job. Is that a possibility?

It was a little hard to tell from the picture, but is it only changing position in the Y axis? If so, there are a few threads on here about that. I’d take a look at those, but some things they tend to mention is check belt tension for sure, make sure the y carriages are riding smooth and not loose, and there is a pot that controls power to the Y axis, that can be tweaked a hair higher.

Good Luck

Yeah, my Y axis has been the hardest to tune. The last adjustment I made was actually to loosen one of the eccentric nuts, but it was easy to tell that it was too tight b/c you could hear the belt skipping when it tried to move.

I don’t know the inner workings of Easel, but hopefully once your gcode is generated, it isn’t reliant on an internet connection. You could test this by loading a project, zero-ing your spindle well high above your project (without a bit), starting it up and disconnecting the computer from the internet.

If that does appear to be the problem, you might want to investigate some offline tools for sending gcode, like Universal Gcode Sender (UGS). It also might be a decent Easel feature request to have it allow you to export the gcode.

Don’t have mine yet, but in a similar question about internet - they told me I could load my project into easel on my laptop, and then be offline for the cut. You just can’t make any changes to the project or it can’t save.

1 Like

You can export the G-Code from Easel. Click on the Machine “menu” and then select “Advanced” in the bottom right corner…

1 Like

@DavidLair hey Dave,
Had the exact same problem with larger jobs to small jobs. Turned out I had to tune the belts of which to me was pretty tight. You should almost hear a tune when you pluck them. I was only cutting MDF, but Zach told me to decrease the depth of cut and increase my inches per minute and that worked. Hope that helps.

well guys i think my Y axis just needed a little more power :slight_smile: thank you all for the excellent ideas and help solving this issue. i’m making a practice cut as i type… so fingers crossed :wave:


Easel does not need an Internet connection to send jobs to the machine. This issue is typically caused by:

  1. Pulley set screw loose causing pulley to skip
  2. Belts too loose and skipping
  3. Current pot needs to be turned to increase current to the stepper motor

@DavidLair Would you be willing to share the step by step process, or even photos on how you did it? Did you have to adjust the pot? It’s one step I did not take, but would like to know in the future how to do it. The instructions weren’t very clear on which dial to tune etc. Any help would be appreciated.

here is what helped me:

just slightly adjust the Y potentiometer by turning it clockwise by a small amount until the Y-axis moves smoothly at rapid speeds (link when moving a long distance while Z is retracted on a large job)

Do not over-torque these pots - they are tiny and gentle and will break. The pots have 270 degrees of rotation.

See here for more detail:

Edit: The pots are usually set at 50% and I just had to tweak mine to maybe 60%


This procedure fixed my machine as well, thank you Zach for pointing me to this thread.
For me I used the Universal GCode Sender to perform this. Once connected I set the step to 20 and backed off the screw on the X and Y axis (my Z was fine) until it would barely move. I then increased it until you could tell it was moving with a roughness to the motors. I then decreased until they just got smooth. Problem solved, no more losing square.

Take some time and read about homing and soft limits.

1 Like

The switches can be both homing and limit switches, it is just a matter of changing one grbl setting.

For turning on limit switches in grbl settings simply change $21=0 to $21=1

I have limit switches on both ends of the X axis and the Y axis, I only have 1 limit on the top of the Z Axis. When I was using grbl (I have since changed out my controller) but they are still wired the same…I tie both X axis switches to the same connection and both Y axis switches together as well.

The grbl controller is prone to electrical noise and I recommend shielded wires for all switches.

Change the setting is all you have to do (and the wiring) and the switches will act as both homing and limit switches.

If a switch is hit the machine will stop all motion…I don’t believe the spindle turns off (I don’t remember).

I home my machine when I first turn on the machine for use every time…so I am using them for both.

A properly configured, mechanically sound machine running adequate feeds&speeds should not loose steps to begin with. I would primarely focus my attention on getting your machine operating properly. When that is done soft limits are quite capable as a fail safe for many scenarios.

Hard limit switches are also possible as a furhter barrier to chaos.

You could use a relay that control all power to the CNC, when tripped power is shut down completely, router and all.

But based on most of your postings recently I think you have a combination of issues, mechanical and feeds&speeds.

Xcarve anno 2015 you say:
Gshield? If so it is not able to provide enough current to your steppers to bring out their potensial. Especially on Y where two steppers share one inadequate driver.
There is also the chance of the drivers overheating which will cause sudden “pause in motion” for the troubled axis until its cooled down again.

If you are willing to lean on the experience of this forum, and make a specific thread for your machine, we may be able to help you. Show us your machine, share your GRBL parameters and feed rates in one place.

That makes it easier for us to help.