SOLVED - Inkscape plugin - problem with laser power and straight line

Hi there Sorry for english :slight_smile: I got big problem with plugin and laser power :frowning: Laser got one power and speed, even if i change settings in plugin. My firmware is 0.9j with modifited hex where i disable spindle and load xLoader. I plug laser in pin 11 and 14 as gnd. Commands M03 / M05 on and off work. Another problem is in curves. If i made project where is simple vector like square line my x-carve make move, laser is on but is to fast to engrave shometing. If i made some circle there laser power is only 100%. If i engrave fonts only laser engrave on curvers but on straight line is moving to fast and dont engrave :frowning: Where is problem ? What i made wrong? I send gcode with Universal Gcode Sender version 1.0.9

Laser engrave red lines with 100% power i think. On blue lines make too fast move.

No one knows ? :frowning:

It’s caused by your acceleration settings for the X&Y axis’s in grbl. Increase the accels and then lower your feedrate so arcs run at the same feedrate as your straight linear moves are.

1 Like

Sorry for stupid question but where i need to change accels and feedrate ? in gbrl setting by $$ ?

My current settings is

$0=10 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=3 (dir port invert mask:00000011)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.020 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=0 (homing cycle, bool)
$23=3 (homing dir invert mask:00000011)
$24=25.000 (homing feed, mm/min)
$25=750.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$100=40.000 (x, step/mm)
$101=40.000 (y, step/mm)
$102=188.976 (z, step/mm)
$110=8000.000 (x max rate, mm/min)
$111=8000.000 (y max rate, mm/min)
$112=500.000 (z max rate, mm/min)
$120=500.000 (x accel, mm/sec^2)
$121=500.000 (y accel, mm/sec^2)
$122=50.000 (z accel, mm/sec^2)
$130=790.000 (x max travel, mm)
$131=790.000 (y max travel, mm)
$132=100.000 (z max travel, mm)

Try these accel settings.

$120=8000.000 (x accel, mm/sec^2)
$121=8000.000 (y accel, mm/sec^2)

Also change this one.

$11=0.005 (junction deviation, mm)

The feedrate should be set in the Inkscape plugin your using for generating the gcode.

1 Like

thx for reply. Ill wil try these settings after christmas :slight_smile: Can you define feedrate in plugin ? that is laser speed or travel speed?

What plugin are you using?

The J-Tech Laser Tool has Travel Speed and Laser Speed, but I’m not sure how they are different from each other. If that is the plugin your using, change both of them to be the same, but lower the value to slow the feedrate down so the laser burns the straight lines.

1 Like

Hi there. I tested that settings but no change, only x-carve make some noise from slow traveling :slight_smile: But bow i load Grbl J-Tech Photonics 0.9g hex file with x-loader. I have lasen on pin 11 and 14. Now i can control laser power with M03 S… but i cant move my x-carve in manual control and its do nothing when i send wile with g-code.

Read this section on the J-Tech Photonic’s web site. It will explain what the problem is that you are experiencing.

"Using J Tech GRBL Version 0.9g"

1 Like

Another thing to check. See if this grbl setting is set this way.

$14=1 (auto start, bool)

1 Like

Hi there.I read this section nad ill make the same things. Another part is $14. On $$ ill got $14=0 if i set this to $14=1 i got message >>> $14=1 error: Not idle

Try a reset, or disconnect from the com port and reconnect and try changing it again.

1 Like

After load Grbl J-Tech Photonics 0.9g and reset still the same $14=1 error: Not idle … and i cant control move on UGCS :frowning: Manualy move axis don’t work. My x carve do nothing od send g-code. Meybe i make some wronk on different place? UGCS ? or plugin problem?

I make gcode with plugis , its simple star

M5 S0

G90
G21
G0 F500
G0 X77.4154 Y13.1999
G4 P0
M3 S63
G4 P1
G0 F500.000000
G0 X49.2818 Y19.7063
G0 X27.9727 Y0.2191
G0 X25.4669 Y28.9863
G0 X0.3485 Y43.2306
G0 X26.9334 Y54.5033
G0 X32.7186 Y82.794
G0 X51.6548 Y60.9937
G0 X80.3485 Y64.234
G0 X65.4668 Y39.488
G0 X77.4154 Y13.1999
G4 P0
M5 S0
G0 F500
G0 X0 Y0
M18

On command table in UGCS it stops on G4P0. Sent is checked . Done no.

The G4 is a pause and it should have a 1 or more value after the P.

1 Like

Still the same i dont know what to do :frowning: After ulpoad Grbl J-Tech Photonics 0.9g i cant control x carve. I remove G4P0 and now stops on M3S63.

OK i reconnect many times and i can now set $14=1 and i can control x carve but very slow. I test some vector look like this

But on laser ill got something like this with no smooth curves

The J-Tech grbl 9g does not support arcs, only G01 linear moves.

Also, you need to read that section on the J-Tech web site about "Using J Tech GRBL Version 0.9g"

1 Like

I solved my problem. Load Grbl 0.9j. Dont make any changes in settings $$. Dont use Inkscape plugin. I make g-code in easel. Replace move z-axis with laser on with power, send with UGS to x-carve and its done :smile: Here is some test samples

1 Like

How do you generate Gcode from Easel? I don’t see any way to export Gcode.