[SOLVED] X and Y axis losing steps

I apologize if this is a bit of a repeat. I am having some issues with the x-axis losing steps. The easiest way to describe the issue is when cutting a circle. I setup easel to cut a 3" circle outline clear through 1/2" birch ply with a 1/16 bit (from the starter set). The first pass looks great and then the second pass is pushed to the right about 1/2 the bit width. That pattern continues on the next pass. At this point I kill the job so I don’t wreck the machine.

I have done the following as suggested in several of the other forum threads.
** Increased the power to the stepper motor (both x and y actually).
** the v-wheels don’t appear to be too tight
** the belt is tight
** the set screws on the stepper motor pulley are tight
** wiring is all secure and snug

I am pretty sure those are all of the things that might be causing the issue. I am guessing I am incorrect about one of the things I listed above (or there is something else to adjust that I am missing. I am hoping someone has an idea since I am running out.

With the power off I move the x-axis at a slow and steady pace and it moves smooth.

I would greatly appreciate any thoughts on the matter.

Your stepper drivers may actually be thermally throttling and shutting down to protect themselves. Or your drive current is still too low. I had the same issue, and turning the current up about 1/8th of a turn fixed it.

Depth of cut and speed?

Thank you for the reply. I really appreciate the help. I am very new to this and the x-carve (got it last week) is my first CNC machine.

When you say stepper drivers are you referring to arduino shield? If so, the cooling fan seems to be doing a good job, but maybe I am wrong.

When you say “turning the current up” are you talking about adjusting the power to the stepper motor using the adjustment on the arduino shield? If so, in the troubleshooting process I have turned them up. I would say it was shipped at 40% and I have turned it up to about 60-70%.

If my assumptions are incorrect, I would greatly appreciate any additional information.

Thanks again for the reply

You need to be careful turning the pots up as there are both, “too low”, and, “too high” settings where they will lose steps.

I could try adjusting that. I am using the defaults as provided by easel for birch.

One other thought is that I also have a problem with the 24v spindle and have emailed the customer success team. It is acting like there is a dead spot in the motor. When power is applied it will sometimes start-up, but most of the time it does nothing and if I turn the spindle a little it will suddenly come alive.

I am starting to think that the spindle is running under powered due to the “dead spot” issue and the additional drag is causing the x-axis to get out of sync.


interesting, I will try turning it down to the 50-60% range and see if there is any change.

Thank you for the information

There is another thread somewhere where they discuss this problem. It is bad wiring in the spindle. That seems like a separate problem.

1 Like

I just created a project in easel that is just a 3" square. When starting the carve, the x-carve creates a rectangle and each pass is off from the previous. Below is a short video of what is happening:

Can’t help with the layers being off - I assume you’ve tried everything mentioned in the other six million threads with that issue: checked your grbl settings, wheel tension, everything is square, belt tension etc.?

For the spindle - starting it with your finger is just wrong. Either you have a loose wire somewhere, or you have a bad spindle.

And what’s that weird sound? Is it just a cheap mic on the video camera, or does it really sound like you took a bag of rocks and shoved them in the spindle? If it really sounds like that in person then something, probably your spindle, sounds like it is shaking itself apart like a rusted out '72 pinto just before all the wheels fall off.

Thank you all for the help. After researching my spindle issues more it sounds like the lost steps are a symptom of the spindle issue.

At this point I am going to assume this thread resolved. If after receiving my replacement spindle, the issue continues, I will add more information to this thread.

Thanks again

Well, that will fix your spindle, but, not losing steps.

Best I can tell from others that are also having the same spindle problem is that the low and erratic spindle RPMs is causing the bit to grab and cause the system to “lose steps”. I am not necessarily putting all my eggs in one basket, but until I get a replacement spindle and either prove or disprove the theory I am going to just let it be.

I will update this thread when I get the replacement spindle so that others that are tracking down a similar situation will have the information.


So, I got my new spindle, mounted it and ran a test. This test changed nothing except the replacement of the problematic spindle. I am happy to report that the replacement spindle did indeed resolve the issue.

I am marking this issue as resolved.

Thank you all for your comments and help.