Inventables Community Forum

Spindle blips for ½ second then stops

Brand new to CNC and getting my feet wet with a very basic 3018. Built and it runs using GBRL Control on a PC, now moved to its’ final resting place on a MacBook Pro. I did notice that using GBRL the Spindle did not want to fire up if the speed was at 10,000, if I dropped this to 2,000 it run fine and I could then speed it up to the 10,000 max as shown. Never really convinced it was running at that speed as there was no noticeable change above 7,000 but anyway, it ran. I never carved with it on the PC.

Now, set up Easel, I am almost at the end of my Free ‘Pro’ experience and as yet not done anything as such. When in Machine Set-Up and testing I can move in all Axis, no issues. Select Automatic for the Spindle and when I press Test, it blips, spins and stops. The power to the board looks like it drops as the LEDs, turn off, momentarily. The LEDs come back on, all axis will move again but no Spindle running.

As the Spindle ran on the PC, under GBRL but not at full speed initially, I wonder if there is a way to start the Spindle at maybe 2,000, then ramp it up? My logic says it is drawing too much power at 10,000 and trips out the supply but at 2,000 it handled it. Does that make sense?

Where do I find the speed control for the Spindle start up speeds?

Would love to achieve something in the next day or so.

Read this thread.

The speeds come after the S and there is a quarter second between rpm levels. I’d recommend increasing the time the first time you do this.

1 Like

Well I read it and I while it may well be the correct way to achieve the start up, without the huge draw of full speed, just how I do all, nah, any of that is right now beyond me. At least in the basic GBRL I was running on the PC, I could start at 800rpm and work up.

Are you saying that there is no way within Easel (not gcoding) to change the speed of the Spindle?

I’m going to jump in and answer this one… in easel you can adjust the operating rpm if the spindle PRIOR to the carve, but not adjust it on the fly mid carve, and the ramping can’t be added within easel.

You’d need to save the gcode file from easel and then either add the ramp sequence gcode to the saved one or use manual controls in a seperate gcode sender program that allows for this.

Many people that I’ve seen using a spindle that requires ramping will setup a macro for the ramping function, and ramp the spindle up. And then send the carve file. This can be done in candle, UGS, or OpenBuilds control :man_shrugging:

Thank you for that clear and concise answer. It may well be that I do not need Max RPM of the Spindle, in fact I am sure I do not. I will now start looking for the spot within Easel where I can start the Spindle at say 2 or 3000 RPM but in the meantime, if you see this post, could you point me in the right direction please.?

Thank You

1 Like

This shows how to enable the spindle and set the cnc max rpm:

Once the spindle is configured per the video, you’d enter the RPM to use for each bit here:

Thank You once again.

1 Like