Spindle Issue

So I have the the Sainsmart 3018 Genmitsu CNC Router, I am trying to set it up so I can use easel as the control center, but the spindle is not behave as I have seen in several videos, any suggestions will be great. I have included two videos and GRBL config

What it does during set up when you test it:

What it does when a job is sent:


Did you ever find out what to do. My Genmitsu 3018 does the same thing when I try to use easel to perform a job. Please reply to tdono8@comcast.net

Wish I had better news but have not had any positive responses to this yet. 109 views and no advice.

It’s unclear what you’re doing to get that response from the spindle. Is it just supposed to be on? How are you testing? What UI are you using for control? Is it wired correctly? There’s nothing in your grbl settings that would cause issues with a spindle. We’ll need more information.

Interestingly, the spindle for my 3018 PRO was also not initiated during the Machine Setup process. But the spindle was spun up when executing a carve. But I also don’t see how to adjust the RPM in the Easel UI. (CNC newby here)

I had the same issue with Easel and Candle (control software coming with 3018 PRO). In Candle the problem was solved by lowering the spindle rotation value to 700 from original 1000. This is the beginning of the “Sainsmart” test pattern after the edit:
G1 Z5 F500
G1 X0 Y0
M03 S700

Still no idea what the problem is, would love to hear some suggestions. Lowering the default RPM in Easel does not seem to solve the problem.