Spindle won't start, after bad night of carving

Last night I ran a job of carving on my XCarve Pro, and this morning when I came in, some block had come loose, and there was a couple of mis-carves.

Now, when I try a new carve, the XY and Z movement are all fine, but when I get to the stop to start the spindle, the spindle won’t turn on.

Today is a holiday, so I can’t call support. Anyone know if the spindle has any kinda reset button…or did I fry the spindle?

FYI, the spindle turns freely by hand. Nothing jammed or caught.
Just won’t turn on.
I’ve performed a complete system reboot to no avail.

I’ve had this happen when the bit hits a clamp and binds. Turn the machine off (as in turn the switch off on the tower). Wait at least one full minute (I always wait a couple of minutes), then turn it back on. Basically a ‘hard boot’. That has always worked for me.

I’ll turn it off overnight, and see what happens in the morning.

Thanks!!

any luck?

I should also have mentioned, that if that does not work, they (Inventables Tech Support) have another way of fixing it. Not sure what that is because turning it off and on has worked for me the few times that it happened to me.

Yup…worked for me.
It was suggested I unplug it from the wall, so I did, overnight.
All good