Starting depth is incorrect since latest driver release

In the last week or so I was advised to upgrade to the Easel driver. Since then, the start depth is out by about 1-1.5mm too high. I zero the Z, as usual, but now when I run the job, it air cuts for a number of passes until reaches the material. Although the bit is 0’d on the surface, you can clear see it starts cutting above the surface. The pieces are flat, and I’ve tried with various pieces. Has anyone else noticed this? Current driver is 0.3.21

Thanks
Jason

1 Like

Hi Jason,
Are you probing the Z zero? if so What is the thickness of your Probe?
Also, what model cnc is this?
and If its an X-Carve does the Z axis have linear rails (the post nov2021 and the optional upgrade for older ones) OR does it have the older version with VWheels?
And If it’s an Xcarve, what are the grbl settings for $102 (this can be found by going into machine inspector by pressing Ctrl+Shift+D and scrolling to the settings at the bottom)

Thanks!

Hi Seth,
Thanks for the reply. It is actually just a 3018 that I am using and I think I may have found the issue, although to answer some of your questions, no, I’m not using a Z probe. What I decided to do was to check the calibration of XY and Z. I set these settings about a year ago and they have been set to 784 ever since. However, for some reason, they are now incorrect. Although not a big change, I have now set them to 800 and that seems to have worked. The amount of correction I made doesn’t add up to the amount the Z was out, but I’m happy with the result.

Chat soon
Jas

1 Like

The saga continues. I realised the issue was solve because I had installed the previous version of the driver (0.3.20) oops and not the re-calibration. So, today I was doing a couple of carves. The first ones were an inlay so I didn’t want to update to the latest driver until I had completed that job. Then came time for the second job.

This job was going to be an attempt to create a VCarve Inlay. So I figured I would upgrade to 0.30.21 driver.
The carve was a 60 degree VBit for the detail, and 1/8 Downcut for the rough pass.
I ran the roughing pass through until it finished, or at least I thought it had. More on that later.
I then switched to the VBit. Everything started fine, but then after about 5 minutes, the job finished. It didn’t stop, it FINISHED. The spindle returned home and the completed box popped up asking if I was happy with the job. I then re-ran the job, and this time it finished after about 20 minutes (run time was supposed to be 1 1/2 hours. Now time for the test. I re-installed V 0.3.20 driver and ran the Vbit path for the 3rd time. This job ran for about an hour and a half and completed successfully. It was during this carve that I realised the roughing pass had NOT finished.
So, I reinstalled the roughing bit and re-ran the job. It wasn’t until the job was about 56% done when it finally started cutting wood and not air. This job also completed successfully. Therefore, it must a driver issue.

Machine: Generic 3018 with 20k spindle
No homing or probes. Fully manual.
The job was created entirely in Easel.
The project failed. :slight_smile: