Strange Issue with New Controller

OK guys. So I thought I would see if anyone else has any thoughts on this. I finally got my @PhilJohnson brand controller built. Got it all hooked up and turned everything on and had some strange issues. I’m no electrical expert but I suspect a grounding issue but I have no idea where.

So lets start with the problem. When all drivers are powered the X is stable and functions as expected. The Ys will sit and make occasional movements. They are small and infrequent but they happen. The Z just jerks all over the place. I suspect grounding because when I touch the Z it stops. This however doesnt stop the Ys.

Now on to what I have tried.

Re-seating all wires = no change
Switching the signal and direction wire from Z on Arduino to X and vise versa = no change
Bypassing all connections on signal, stepper on and direction wire and going straight to Arduino = no change
Swapping green Molex connectors between drivers = no change

Now for the part that I dont get

Swapping Z and X drivers = both now work mostly as expected
I tried the same for the Y steppers and its mostly good, HOWEVER, there are still tiny jerking movements occasionally coming from one of the steppers. The movements are now so small and infrequent that I am having difficulty figuring out which stepper its coming from. I have everything commonly grounded to the V- terminal on the power supply except for the shielded cable which is earth grounded. The only thing I could come up with is bad connections within the driver itself. I see that the most recent Amazon reviews on them have not been favorable which makes me sad.

Anyone else have any thoughts on something I didn’t try before I try and send the drivers back? Was hoping to get it back up and running before Christmas so I can finish a gift but its fighting me. :disappointed_relieved: Below is a clip of what it was doing.(temporary location/don’t mind the clutter) It’s now very subtle. Thanks in advance for the suggestions/help! :grin:

Lmao… Well that might be the problem. I guess my boss who helped me with the wiring and myself both had a special moment there. I’ll fix that up tonight.

Thanks Phil. I’ll also take another look at the wires in to the drivers when I get home. If its a loose strand it will be there as I used solid core for the signal wires. I do have the stepper cables grounded on one end to AC earth ground.

1 Like

Thanks Phil for pointing out my special moment. Runs like a champ now.


I use shielded wires for mine. Had similar strange issues with things.
Glad you got it working.

1 Like

The Xcontroller do have RF noise suppression circuit in place for the limit switches now.

Only for limit switches and probe input. The motors are direct connected to the TB6600 chips.

True, I have clarified my post.

Glad I saw this before wiring mine up one less headache for me. Although still not sure what grounds where then. Does anything ground at V-? Also no clue what I should be setting all my dips for. I’m going to start this mess this weekend I can’t build much more of the machine till I get my pulleys and been saving the controller for last.

Just a nit pick, but the probe pin also has input filtering.


I use shielded wires on the motors as well.

1 Like

Everything is shielded :slight_smile:

1 Like

You are correct.

In my defense, I was correcting his statement of motors and limit switches and failed to mention the probe due to the scope of my intended correction. Edited my post.

1 Like

Well now that everything is grounded correctly and I have the steps per mm set correctly it runs like a dream. HOWEVER. :grin:

I am having a bear of a time with the homing switches. I am running them normally closed with the capacitors to filter noise. This is what my wiring looks like

So when I run homing I get no response from the switches. I have homing enabled and $5=1. Trying to think of the best way to test them.I also tried Larry’s troubleshooting method but am getting a strange result after doing $10=19. I dont get LIM000 at the end. I still get position and work position which are all 0 as expected. At the end I get PIN 000.

Best guess from your comment is that you are running version 1.0c of grbl. Take a look at this thread for reference.

Those capacitors look fairly large, what value of capacitance are you using?

He is using electrolytic capacitors. They are polarized. He has them hooked up correctly.

My guess is they have large capacitance values.

1 Like

Hey guys. thanks for the responses. They are .47uf electrolytic capacitors. My boss, with whom I am working on this joint venture with, uses them on his drones.They are polarized. And Yes Larry I am running 1.0c.

OK so now when I have 10=19 I should see PIN000 instead of LIM000 Correct?

Yes. Since you’re running 1.0c then go ahead and change $10=115 just in case you might want to use a Z probe at some time.

1 Like

OK guys. Hopefully someone might know whats up with this machine. I am pulling my hair out with it. So it was running beautifully except for the homing switches on the 13th. I set it aside due to the holidays and other things I had to do.During that time I was doing some reading and believed I had figured out the switch issue (wiring on my part again) So I come back to it today and its all kinds of screwy. Mind you nobody has touched it since the 13th of December.The only difference is it is now very cold here. It smells like software to me. All 3 axis are misbehaving. I re flashed the Arduino and that got it at least working. So before I did that it would occasionally take a command. Say I jog y towards me, it would move, but if I clicked jog in the same direction again it would do nothing. Now its responding every time but its not moving the same distance between forward and back and left and right. Some movements are nice and smooth while others are very jerky. The Z seems to be the worst. It doesn’t even want to move. I am attaching two videos. One I took on the 13th and one just a bit ago. I am open to any ideas at this point. Thanks for the help.



First place to look is at the grbl settings since you modified the grbl firmware. Post them here.