Struggling with easel

so I’m sure many of you have seen me on the forum as the newbie.
I want to buy a cnc machine, but I’m very afraid that I wont be able to use the software.
I have searched for tutorials but have found very little.
I have been playing with the easel program but under no circumstances can I up load a file.
I continually get the message “vectorizing failed: networking error: invalid argument”
I have no idea what it means or what I’m doing wrong.
I get the same message with jpg files svg files and dwg files.
I just cant send the money on a machine until I’m comfortable that I will be able to run it.

You can look through some of these tutorials to get familiar with how you design things for a CNC machine. You can download trial versions of this software to “work along” with the tutorials. Once you get familiar with the process you can go back to Easel if you want and it should make more sense to you then. Start with the Vcarve Desktop tutorials.


Hey Jan so I run a YouTube channel called ontheEdge and I would love to make you tutorials about some of the issues that you are having

here is my channel

you can contact me via email

Thank you everyone for the very helpful responses.
I have been watching the video tutorials with great interest.
I really need to feel comfortable with the software before I pull the trigger on a machine.
I also received an email from Inventible and they too are very interested in my problem and helping me out. (which says a lot about the company because I haven’t even purchased a machine yet)
It appears as tough others have had this problem also.

funny I have never gotten Inkscape to work lol I mostly use the web one or v-carve pro or just pay someone to do it on more complicated ones


alright yeah I will keep that in mind I really dont use it much cause I suck at drawing and anything technical that I draw in done in Fusion using sketches but yeah might need help time to time


1 Like

I had this problem when I was first looking into the Xcarve…I was trying to do it from my office on lunch break. Got the same messages, and turns out it has to do with the company server and the security settings. Once I tried it from home on my computer I was able to do it just fine. So check your network security settings. If you are trying it from a company computer they may have stuff blocked.

thanks for the response.
it does the same thing either from my company computer or my home computer.
I’m currently looking into other software’s that I may be able to learn.


could you please provide me with a file that you are trying to upload so I can take a look at the problem?

I just sent you the files.
thank you all for your help.

If you’re trying to import an SVG and it’s not working, try opening it at and saving it as an SVG from there. For some reason Easel doesn’t like some of the SVG’s I make, but it will almost always accept a MakerCam SVG.

If you’re not sure how to do that, I showed it in my SketchUp-to-Easel video that I recently released, there’s a link near the bottom in this thread: X-Carve Maintenance/Troubleshooting Videos - Add Your Own!