Inventables Community Forum

Think the board is burned but have you ever heard of this?

I was in the middle of a cut when my computer screen went black and I started to smell a whiff of that burning electronics smell. Was not sure if it was the laptop or the arduino but tried to find the smell and it was not obvious where it was coming from. I booted back up and the pc could not find the port for the arduino and it was not in the device manager.

I tried a different usb port and heard this noise coming from the stepper in the attached video Anyone ever heard this?

I imagine I will just swap out the arduino as I know of no other option, but just wondering why the stepper would make this noise suddenly? Any thoughts on what may have happened?

I have had that on a few of mine, that whine sounded like high oscillation frequency than any stepper can emit.
(rotor locked in a position where is oscillate ever so slightly back´n´forth.
Is not a sign of defect in itself.

If you were to jog that stepper the whine would most likely change in pitch slightly or go away entirely.

The driver could still be bad though.

Thanks Haldor, will give it a try.

So may have spotted the problem, you think? :slight_smile:

I have a new gshield and replaced my burned one but no go. So I wonder if the short circuit in the old gshield burned out the old arduino?
So I took the new arduino and filmed a comparison between the new and old boards in the video can someone tell me if the old board is shot?

Now I am trying to install a new gshield and have. the following issues.

  1. On the original laptop have lost the arduino and com port completely in the device mgr.- reinstalled arduiino ide, nada, checked the net for solutions on Arduino ide and win 10 gave it a try, nothing works.

Result: no arduino and no com port, tried the legacy install on com ports and just shows com 4 with a trouble icon.

  1. tried unpluging the usb from the laptop and setting up a second computer. now see comp port but after installing arduino see no arduino in the device mgr

3 setting up a third computer. plugged in same results see comp port but no arduino in the device mgr

I am at a loss, any help would be appreciated

I think you lost both Arduino and gShield.

Try hooking up the new Arduino without the gShield and see if you can establish communications with it that way.

Hi Larry,

Tried that too loaded arduino ide on all 3 computers and it does not see the arduino in the device mgr on any of the 3

I agree with Larry. Based on the computer black screening on you and the burn mark on the gShield, the Arduino likely took a hit as well.
You might want to try connecting to the new Arduino with a new USB cable.

I remember something about this particular setup not playing well with the current version of the Arduino IDE.

Hard to re-insert lost magic smoke… :frowning_face:

Old boards are toast (both), toss them and start fresh.

1 Like

Better to use a known good .hex file and Xloader than to regenerate grbl from source. If you are not very familiar with the process it’s easy to mess it up. Some versions of the Arduino IDE are better than others.

Hi Steve.

Thought I might give your suggestion a try as all 3 computers do not see the arduino PCB when I plug it in. I was doing fine till I got to this “Before you upload the sketch, make sure you have your board plugged in and selected under Tools - Port - xxxxxx(Arduino Uno). For PC users, you can verify the Port by checking in your computer’s Device Manager.”

So under Tools I only have “Port COM1” with no mention of Arduino. And as mentioned it does not show up in the device mgr Not sure where to go from here

Larry how would I find instructions on your suggestion using Xloader?

1 Like

You are going to have to solve the COM port problem before you can proceed. All programs use the COM port to talk to the Arduino.

It doesn’t seem like you are getting a valid Arduino driver installed, or your hardware (USB port, USB cable, etc. is not working correctly).

Thanks Larry, I have a new USB cable now, same result. I am using 3 different computers all with the same result and usb ports, so now I am wondering about the new Arduino board I have…getting frustrating

Funny thing is I can hear the xcarve respond when I plugin the cable (you know how it make a thumping noise when you plug in a cable and locks into place)

When the Arduino gets power it initializes itself. It just could be a random signal that causes the X-carve to respond.

It’s possible that he new Arduino has grbl on it if you ordered it from Inventables.

Looking at your video it appears that the new Arduino board is coming up correctly, but with three computers and a new USB cable the new board could be bad.

I did order it from Inventables. So just to be sure I should be able to take the Arduino board with nothing more than a USB cable, plug it in, and it should be recognized by windows and show up in the device mgr correct?

Yes. That’s correct, assuming you have installed the Arduino IDE to get the Arduino driver.

Ok thanks, Looks like I am talking to Inventables for a new PCB

1 Like