Touch plate issues

i have the older model not all in one. thinking about upgrading to all in one that they sell now. but i dont need the other pieces in the kit. i pulled out the adurino board. and added a wire to a5 and a0. all hooked back up and the machine will not move unless both a5 and a0 are connected. when they are separated, ugs says alarm. and will not allow the machine to jog. but when i connect a5 and a0 the machine will move where ever i want util the connection is broken.

i am making my own touch plates. that way i can have the 3 that i would like for what i am going to use this for.

only other things that changed latly are;

doing these pins. my homing switch’s dont work. they never have. figured i would look at them when i did this. i dont really need them. they were added to my phone order so i installed them.

i cleaned up the wiring some. removed the wires from the terminal block and added a spade connector and heatshrink to each one. tested machine after doing that and all worked for what it needed. then re tore apart to do the a5 and a0. and now nothing unless connected.

Can you provide some pictures of your wiring?

A0 is the reset input. A5 is the probe input. They should both be at a logic high when inactive (about 5 volts).

the side where the other y is switched here. other side is color for color. this one is red is white and blue is red for the motor like instructions say.

back of the z.

when these 2 wires are like this it doesnt move. when connected it works like normal.

limit switch’s(dont work)

motor connections.

the a5 and a0 pins.

clears the housing so not grounding out there. (made the slot more then enough.)

donnno if these help at all. i am gonna look for my volt meter.

when i remove the pins from a0-a5 it functions as it should.

When you find your voltmeter, check the voltage on the wire coming from A0 and the wire coming from A5 without the two hooked together.

I had mine connected to the ground on the front pwm connection. And the hit to A5. When I used thebprobe I would have to flip the switch up.

Tonight if i have time. I am gonna just insert a tinned wire into a5. And see if the machine moves. Might be the pins i used are to long is my only guess. Or that i do have a pin in a1-a4.

Making a new case is not hard. i do have a 11ft sheet metal break.(little over kill for this but its what i got for work making my own flashing gutters and stuff like that) i dont have time before i leave to try tonight. but when i get back from the trip i will pick this up again and work on it then. it will work sooner or later. it does now just not the touch plate.

The logic switch

Hmmm idk. I don’t pretend to have this super power lol. Me and electricity don’t really get along. All I know is my probe worked great in the A5 and the the S- as long as the logic switch was “on”. I seem to recall a video I saw from @CharleyThomas a while back that hooked it up there. (That’s why I did it). However looking at the front of my P/S interface the down position is “logic” and the up position is “on”. While the middle is off. Both however seem to have a ground.


Please post a picture of the wiring to A5 and the wiring to S-.


1 Like

The A-5 connection to the Arduino is correct. The other wire goes to the power supply main ground connection which is right next to the spindle power. When correctly connected you will have 4.7- 5 volts between the touch plate and the bit. Here is a video on wiring up the touch plate. If you skip to about 1:28 it shows the ground connection.

1 Like

I was actually just rewatching your video. Yep hooked it into the wrong spot. But it worked. Used it like that for a while until I got my X-Controller.

S+ and S- are both positive?

Ah. I said the switch to “on”. Then said logic so you would know what switch I meant. I was connected to the S- Which is irrelevant because it is wrong. lol. Not sure how I got that out of Charlie’s video. But I did. And it worked.

1 Like

That vid helped me visualize where the ground part goes. I might spend the 10 min after work before i drive 1300 miles for my trip tonight.

1 Like

had a few minutes before the miss’s gets home. put a solid core wire in the a5 pin. and out the front. then soldered my braided wire that i ran threw the machine for the mount i am making. ground went to the one in the video.

now in UGS when i send the command it starts to move EXTREMLY SLOW!(i know f1-slowest it can go) i connect the 2 wires together and it just stops moving. not like the one vid i watched where it would go back up to where it started. ill have to mess with that in a week.(monday night)

so a0 is not a good place to get a ground from i guess. who knew. (NOT ME!) ima add a pin and a plug to it so it is removable for when i am messing with it i can connect/disconnect without having to remove my wire staples and everything else that makes it so the wires dont have room to move.

side note figured out why chilipeppr wouldnt load for me. i have to be in internet explorer not Mozilla. but i cant get the machine to connect threw chilipeppr(had 2 minutes to play with it.)

also called alro steel(local suppler i go threw.) and asked how much for a 1000mmx1000mmx.25 and they said 200 for the plate and 30 to cut it. will shop around for a better one was just starting to get a price check for it. have seen on the forums people pay 110 plus 30 shipping. figured if i could get it for 150 total i would just do it and not wait for shipping.

for a 2x2x1 cube it is $1 for the cube and $3 to cut it. so i am gonna buy two and a new alum milling bit to start milling the few blocks i need/want to do. in the end it will be cheaper then ordering the ones i would like.

thanks for the replys.

A0 is not a ground. It is the reset/abort input for grbl.

could of sworn i read somewhere a0 was ground. doesnt matter tho. got it in the end. now to make the blocks and get the macros set up in ugs.

F1 is slow in inch mode, F1 is slooooooower in metric mode.

1 Like