Touch probe help

Z probe function was working then it started
When i do a probe it works fine but when move xyz axes to remove touch plate and go back to zero the x,y are correct the z try to go through the spoil board

Some more detail would help.
Are you using only Easel for design and control?
After probe why do you move Z to set x and y?
Have you made any changes to software version or GRBL settings?

V-carve desktop
UGS platform64
Probe works fine when i remove touch plate and press go to zero cnc moves to x y location fine z axes moves down past zero I have to hit the stop

The probe function works fine using SourceRabbit

I have not made any changes to software

I think you have to tell UGS what the thickness of your contact is so it subtracts the correct amount.

Setting are correct
It worked fine in the beginning
I also tried to reinstall UGS platform64
I also noticed when i reinstall UGS that the probe setting are still there
Shouldn’t they have to be reinstalled

Check this thread.

Nothing worked I give up

I also tried to adjust the retract height if I go anything above 10 it doesn’t retract the z axes pushes on plate

Can you get a screenshot of your probe settings?

I had similar problems with my z axis driving into the wood after leveling it… my problem was the set screw had come loose on the z pulley and so it was slipping when it had a load on it but not when it was z probing… check those set screws… I ended up removing them and put longer machine screws in the so they would bite into the z axis better…