Inventables Community Forum

UGS Failure

Hi all. I typically use Fusion 360 and UGS for my projects. I recently “upgraded” to GRBL1.1 and UGS Platform and am now having trouble getting my projects to complete. Specifically, they generally stop part way through with the message ALARM:1 [MSG:Reset to continue]. Any idea what is going on?

ALARM:1 in 1.1 grbl is a hard limit error. If your machine didn’t stop at one of the switches then most likely you have hard limits turned on and you are experiencing electrical noise on the switch wiring.

Thanks. I suspected that. Any idea as to the best way to eliminate the problem?

Depends on how you want to operate your machine.

Here is my suggestion:

Turn hard limits off. Turn soft limits on. Home your machine.

I won’t preach the value of homing, there are plenty of threads here that talk about it. Same to be said for soft limits.

The idea behind this is that if you do it that way, then once you have homed your machine with soft limits turned on, then from that point forward grbl does not look at the switches no matter how much noise is on them. If the homing sequence completes normally (something that is easy to verify) then you don’t have to worry about the switches.

1 Like

Some electrical signal noise can be reduced and/or eliminated using these:

Your mileage may vary.

The capacitors were an easy install and appear to have fixed the problem. Thanks again for the advice.

1 Like

I’m having a similar problem. I ran my XC with UGS for 3 years with no problems and then I let it sit for a year. Hard limits are turned on. I can home it with no problems and jog it around, run the z probe macro. The minute I start a carve, the machine starts to move and then triggers an alarm. This is very interesting as nothing has changed from when it worked. I may try the soft limit switcheroo mentioned above. I didn’t know you could home the XC with hard limits turned off and soft limits turned on.

– Update: Interference seems to be the case. I turned off hard limits and used soft ones instead and now it cuts. Very interesting how that is the case and I haven’t changed anything near the machine. I originally thought maybe my new UFO Bay Light above the rig was causing problems, but I turned it off and still had the problem.