UGS no seria port found

Hello everyone my name is Jose, and I’m newbie on run my mill machine with a OpenSource software like UGS, so I tried run my mill but when I plug my machine and choose the firmware: GRBL then look for any Port the error comes with the next message: “No serial ports found”. The model of my CNC board is BL-USBMach-2.1 and when I ran my mill on Mach3 it didn’t exist any problem, I could control the machine.

I thought the problem is the driver but I didn’t find any driver for that, besides on Mach3 didn’t need driver only the plugin with USB. I tried in two Operative Systems like Linux and Windows, the problem still remain.

So any ideas to resolve this problem, I would be so grateful!

1 Like

try this one, its much better.

OpenBuilds Software - FREE Software for CNC Control: OpenBuilds CONTROL and OpenBuilds CAM

Make sure you download and extract the software from the computer set up section of the x carve assembly.
easel

It doesn’t work, the same problem, not identified the USB

1 Like

you have a mach3 controller, this is proprietary and will not work with opensource Grbl controllers like UGS, OpenBulds, Picender, GSender, Candle, or any other basic Grbl type of sender.

you would need to replace the controller board with a Grbl type of controller, or Pay for Mach3.