UGS problem

On my x-carve, I use a Universal G-code Sender (UGS) for getting the machine moving on detailed 3D machining. I create the Gcode in Vcarve.

I have been using the UGS Platform for a few years now and my PC updated about 4 months ago, and even though I have tried many times, to load the UGS Platform, it just won’t load.

I have totally unistalled the UGS program and downloaded the latest version, but still, i cannot get passed the “done loading modules”

I have updated the Java platform…

I don’t know anyone else, into CNC machines, that may know the reason that the update, stopped the UGS.

The older style UGS Standard , still works

Any advice or guidance would be appreciate, please

Regards
Kel

Here is the picture where it stops

Do you have virus protection that maybe hindering?
If you don’t think that is the problem try link below and submit a support ticket.

I would just use the old version that works and is stable.

Thank you Mark, I didn’t know they had a support function…I will try it and see if i get a response

Thank you Martin, but the platform is a much better version as you can manually change the feed rate easily

Regards
Kel

Mark
I tried that support function, but they advised as it not their self-hosted GitHub Eneterprise Server product, they could not assist.

Any other ideas please ?

Regards
Kel

Try this site.

Mark
When opening the UGS platform , if i end task (jogamp_exe_tst2779056399215072679.exe ) twice, it loads up
Do you know what this file does ??

jogamp_exe_tst2779056399215072679.exe

Regards
Kel

Sorry I do not use UGS.
I could not figure out the user interface.
I use CNCJs as a sender. The UI was more intuitive for me.

Ok

Thank you Mark

I will use the work around

Regards
Kel

wanted you to know that the developer for USG answers on this forum at times.

@WillWinder might be able to help.

also you might need to downgrade to java 8

Kenneth
Thank you, but I have Java 8 update 231, installed.

Unless there is an earlier version that i could try ??

Kel

You could try one of the new packages which embed Java (so no version issues to worry about), follow the link for your platform: download link

If that doesn’t work, here is the link @MarkA.Bachman was trying to share: UGS Issues

Thank you WillWinder
Very much appreciated

Even with using that download link, you provided, my PC still hangs up…on that jogamp_exe_tst2779056399215072679.exe, line. I can see a little blue ring circling , so it seems to be working but not doing anything.

So I will still use the work around as I assume that it is my PC’s problem and not your program.

Regards
Kel

Picture again where it stops

Lo resolví borrando las preferencias.