Inventables Community Forum

UGS showing Alarm error only when Homing is enabled

Don’t know if this is just the way things are in UGS (…and I do mean Universal G-Code Sender) but whenever I have our 500mm machine setup to allow homing, I have to unlock UGS because the alarm is going. I may be wrong, it does happen, but I thought that that UGS would use the Limit switches for more than a homing mechanism. If it had worked the way that I thought that it would I would not have a Z axis switch in 12 pieces. I’ve looked for solutions wherever the net has taken me (believe me, I should have come here sooner). I’m glad the switches are inexpensive, because I have crunched 3. If machine had stopped when the switch was tripped, then things would be rosier here…obviously. now it could be that there is some simple setting that needs to be switched or a version upgrade that needs to happen. UGS says it is up to date, but is on an XP laptop.

Any guidance would be helpful and appreciated.

@DrewTaft
Hi, Drew.

When Homing is enabled and the machine is turned on Grbl goes into the Alarm state which shows up as the Alarm state in UGS because the software has no idea where the hardware is positioned. You have to Home the machine($H) to clear the Alarm. Once Homing is accomplished then the software is synchronized with the hardware and knows where Machine 0,0,0 is.

You can check this thread for more information. It is one of many threads on this topic on this forum.
Breaking homing switches - slamming the spindle to a rail? No need to

so let me get this straight, instead of turning off the alarm I just need to home it. Once it has been homed, I then go to the material Zero, and click reset zero to start my carving. How do I set the soft limits or is that done during the setup process through Easel based on the work area set there?

Thanks for the insight and tremendous help.

thats correct once you home, UGS will know where machine zero is. then you just need to set material zero, typically the left bottom corner of the material, and hit reset zero before making a cut

if you just need to jog your machine and dont need to home it, you can either type $X into the command line or there should be a $X button on the machine control panel. this will turn off the alarm lock. you should however still home the machine before cutting

soft limits can be set in the GRBL parameters. im not specifically sure how to do it but if you type $$ into the UGS command line you can see all the options

@DrewTaft

Re-post from another thread ----------

If Homing works correctly on your machine then your hardware is working correctly.

Here are the Homing settings"

$22=1 (homing cycle, bool) — enable Homing
$23=0 (homing dir invert mask:00000000) --------- varies depending on your wiring
$24=25.000 (homing feed, mm/min) — default
$25=250.000 (homing seek, mm/min) — default
$26=250 (homing debounce, msec) — default
$27=1.000 (homing pull-off, mm) — default

If you want to stop your machine from going outside the work area then you can do that with soft limits.

The Grbl setting for soft limits are:

$20=1 (soft limits, bool) — enable soft limits

$130=290.000 (x max travel, mm) ---- default value for X-carve 500mm
$131=290.000 (y max travel, mm) ---- default value for X-carve 500mm
$132=100.000 (z max travel, mm) ---- default value for X-carve 500mm

I had to change $132 for my X-carve 500mm to keep the spindle on the Makerslide. You need to test it on your machine but I think I ended up with 88.

Once you have done the Homing cycle you don’t have to worry about interference on the switches because when soft limits are turned on the switches are ignored after Homing and the software will not let the machine go outside the space defined by Machine 0,0,0 and the max travel limits set in Grbl.

This only works correctly if you leave Machine 0,0,0 at the Home position.

Just to be safe I Home my machine prior to each job.

2 Likes