UGS wont open?

Ok, so I tried out win 10, didnt like it since it wont support my 2nd screen which is a vga monitor.

I revert back to win 7 and now UGS wont open up. I dumped and reloaded the latest version of java (32 bit) wiped every instance i could find of UGS and redownloaded “UniversalGcodeSender-v1.0.8”

and tried installing it. it seems to extract files, install etc, but I get nothing on my screen when I run the batch file.

I open my task manager and if I have tried several times to open UGS i will have just as many instances of “javaw.exe *32” under processes.

It seems that github assumes that the users know just what to do since I have not been able to find any solutions there.

How I got UGS working in the first place is beyond me at this point.


1.8 would not open for me. I downloaded the 2.0 version (daily build) and it worked fine



thank you, ( i like it here on da forums…)

1 Like

So 2.0 worked?

I had a problem with it not opening until i moved the jar file to my desktop and then it opened just fine

Yeah it did alot more than 1.0.8 did thats for sure. It connected and I was able to jog the machine etc.

Bad wolf, if 2.0 give me heartburn I will try your suggestion. thanks!

1 Like

How? I have 2.0 and cant get it to do anything but give me an error: No supported kill alarm lock method in this version. And other unsupported bla bla bla…

Not sure what you may have going on, when I downloaded 2.0 I had a fresh install of java. That may have some influence on how 2.0 runs.